geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russell E Glaue <rgl...@cait.org>
Subject Re: Java 5 or 6 for G3.0, and 7
Date Mon, 20 Jun 2011 19:46:07 GMT
On 06/20/2011 02:36 PM, Kevan Miller wrote:
> 
> On Jun 20, 2011, at 1:44 PM, Russell E Glaue wrote:
> 
>> That is what I assumed.
>> But the build documentation suggests otherwise:
>>
>> https://cwiki.apache.org/confluence/display/GMOxDEV/Building+Apache+Geronimo
>> "You will need a JDK 5.0+ (J2SE 1.5.0+) ... Java 6 works with trunk and 2.2.
>> Earlier versions may have problems. Trunk is likely to require Java 6 soon."
>>
>> I am going to update the page to make sure there is no confusion about the build
>> requirements.
> 
> Thanks!
> 
> Yes, we're definitely past the point where trunk has started to require Java 6... 
> 
> With regard to Java 7 -- as Java 7 becomes available, I expect people will start to run/test/build
with Java 7. As has happened in the past (with Java 5 and Java 6), we'll tolerate this, but
not require Java 7... Not until we're looking at Java EE 7 support, anyway...
> 
> --kevan
> 

Good. I have the answer I was looking for.
Geronimo 3.0 is locked in to Java 1.6.
And G3.0 will be released with only support for Java 1.6.

-RG


Mime
View raw message