geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russell E Glaue <rgl...@cait.org>
Subject Re: Java 5 or 6 for G3.0, and 7
Date Mon, 20 Jun 2011 17:44:50 GMT
That is what I assumed.
But the build documentation suggests otherwise:

https://cwiki.apache.org/confluence/display/GMOxDEV/Building+Apache+Geronimo
"You will need a JDK 5.0+ (J2SE 1.5.0+) ... Java 6 works with trunk and 2.2.
Earlier versions may have problems. Trunk is likely to require Java 6 soon."

I am going to update the page to make sure there is no confusion about the build
requirements.

-RG


On 06/20/2011 11:50 AM, David Jencks wrote:
> Hi Russell,
> 
> javaee6 requires java 6 so if trunk compiles at all on java 5 that's a big surprise :-)
> 
> So far we haven't discussed java 7 at all.  
> 
> thanks
> david jencks
> 
> On Jun 20, 2011, at 8:14 AM, Russell E Glaue wrote:
> 
>> I know we recommend Java 6 for trunk (G3.0).
>> But are we now requiring it?
>> Or is Java 5 still supported?
>>
>> If trunk still supports Java 5, is there a foreseable time when support for Java
>> 5 will end?
>>
>> G3 Wiki: Installing prerequisite softwares
>> https://cwiki.apache.org/GMOxDOC30/installing-prerequisite-softwares.html
>> This doc states G3.0 is build on Java 6. It would make me assume Java 5 is not
>> supported.
>>
>> I am wondering in the case that Java 7 is supposed to be released this year. Is
>> there a track to release G3.0 on Java 7, or will Java 7 be the target of a
>> future revision (e.g. G3.1)?
>>
>> -RG
> 

Mime
View raw message