geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alasdair Nottingham (JIRA)" <j...@apache.org>
Subject [jira] [Created] (GERONIMO-5872) geronimo-servlet_3.0_spec-1.0.jar incorrectly applies semantic versioning to servlet packages
Date Mon, 21 Mar 2011 11:38:05 GMT
geronimo-servlet_3.0_spec-1.0.jar incorrectly applies semantic versioning to servlet packages
---------------------------------------------------------------------------------------------

                 Key: GERONIMO-5872
                 URL: https://issues.apache.org/jira/browse/GERONIMO-5872
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
          Components: specs
    Affects Versions: 3.0-M1
            Reporter: Alasdair Nottingham


The gernomio-servlet_3.0_spec-1.0.jar incorrectly exports the javax.servlet packages as 2.6
and 3.0. The problem with this is if the Servlet spec were to make a semantically breaking
API change the correct next semantic step for the javax.servlet packages would be 3.0. This
means there is no way for an importer importing at [3.0,4.0) to know whether they will match
the version that is the same as 2.6, or the version that is breaking from 3.0 resulting in
deployment and runtime problems.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message