geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Louis MONTEIRO <jeano...@gmail.com>
Subject Re: error when building geronime on wondows
Date Wed, 09 Feb 2011 16:04:59 GMT
Hi,

I also got that error some days ago.
The trick is to add the system property -Dfile.encoding=UTF-8 to your maven
command line.
Don't forget to increase your memory.

Under Cygwin (Windoze), I use -Xmx1024m -XX:MaxPermSize=512m
-XX:ReservedCodeCacheSize=64m

Hope it helps.
Jean-Louis

2011/2/9 mohamed.chebbi <mhmdchebbi@gmail.com>

>
> hi all
>
> i got this error when building geronime on wondows xp:
>
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] could not package plugin
>
> Embedded error: Error parsing web.xml for portal-driver.war
> Invalid byte 2 of 3-byte UTF-8 sequence.
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 24 minutes 5 seconds
> [INFO] Finished at: Wed Feb 09 15:52:53 CET 2011
> [INFO] Final Memory: 532M/989M
> [INFO]
> ------------------------------------------------------------------------
>
> someone know this?
>
> -----
> best reguards
> --
> View this message in context:
> http://apache-geronimo.328035.n3.nabble.com/error-when-building-geronime-on-wondows-tp2459273p2459273.html
> Sent from the Development mailing list archive at Nabble.com.
>

Mime
View raw message