geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevan Miller (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-5837) NPE during second deploy using hot-deploy directory
Date Mon, 28 Feb 2011 16:01:36 GMT
NPE during second deploy using hot-deploy directory 
----------------------------------------------------

                 Key: GERONIMO-5837
                 URL: https://issues.apache.org/jira/browse/GERONIMO-5837
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
            Reporter: Kevan Miller


I deployed an application, verified the application was deployed, undeployed the application,
verified the application was undeployed, then attempted a second deploy of the application
using the hot-deploy (i.e. 'deploy') directory. I got the following error on the server:

{code}
2011-02-28 10:54:17,062 ERROR [DirectoryMonitor] Error during hot deployment
java.lang.NullPointerException
	at org.apache.geronimo.kernel.repository.Artifact.create(Artifact.java:59)
	at org.apache.geronimo.kernel.repository.Artifact.create(Artifact.java:51)
	at org.apache.geronimo.deployment.hot.DirectoryMonitor.doRemoves(DirectoryMonitor.java:183)
	at org.apache.geronimo.deployment.hot.DirectoryMonitor.scanDirectory(DirectoryMonitor.java:258)
	at org.apache.geronimo.deployment.hot.DirectoryMonitor.run(DirectoryMonitor.java:219)
	at java.lang.Thread.run(Thread.java:680)
{code}

The mechanism of the initial deployment doesn't seem to matter (deploy command or hot-deploy).

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message