geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (GERONIMO-5783) WAB is lost when geronimo restart after a hard stop.
Date Thu, 03 Feb 2011 01:38:28 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-5783?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jarek Gawor resolved GERONIMO-5783.
-----------------------------------

       Resolution: Fixed
    Fix Version/s: 3.0-M2
         Assignee: Jarek Gawor

Added eclipse.stateSaveDelayInterval = 1000 to etc/config.properties (same as Karaf has).
The change was committed to trunk (in revision 1066151) and M2 branch (revision 1066153).



> WAB is lost when geronimo restart after a hard stop.
> ----------------------------------------------------
>
>                 Key: GERONIMO-5783
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5783
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: osgi
>    Affects Versions: 3.0-M2, 3.0
>            Reporter: Shawn Jiang
>            Assignee: Jarek Gawor
>             Fix For: 3.0-M2
>
>
> equinox osgi state file does not get generated if hard stop geronimo server.    therefore,
 the installed wab is lost when gerinimo restarts.
> Per [1], set "eclipse.stateSaveDelayInterval=0" in etc/config.properties will make the
bundle state persistence occur when there's bundle state change.
> But doing so will slow down the performance if the app contains large set of bundles.
Geronimo is an example of this. I tried the property and the startup time is increased remarkably
due to frequently state disk writing.
> [1]https://bugs.eclipse.org/bugs/show_bug.cgi?id=298416

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message