geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick McGuire (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (GERONIMO-5801) jaxb-impl bundle should export com.sun.* packages with a version
Date Wed, 09 Feb 2011 13:49:57 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-5801?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rick McGuire resolved GERONIMO-5801.
------------------------------------

       Resolution: Fixed
    Fix Version/s: 3.0
                   3.0-M2

Committed revision 1068885.

> jaxb-impl bundle should export com.sun.* packages with a version
> ----------------------------------------------------------------
>
>                 Key: GERONIMO-5801
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5801
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: osgi-bundles
>    Affects Versions: 3.0-M2
>            Reporter: Jarek Gawor
>             Fix For: 3.0-M2, 3.0
>
>
> jaxb-impl bundle should export com.sun.* packages with a version. Otherwise, if for example
somebody exports com.sun.* packages with version 2.1 for JAXB 2.1 implementation, the Geronimo
server and rest of the code will wire to the wrong com.sun.* packages.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message