geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: [Vote] Geronimo Eclipse Plugin 2.2.1 RC2
Date Thu, 06 Jan 2011 17:14:52 GMT

On Jan 6, 2011, at 12:04 AM, han hongfang wrote:

> Johannes,
>  
> First of all, thank you for trying the patch on MacOS.
>  
> I don't see woodstox:wstx-asl:jar:3.2.1 in any pom of GEP 221. So I think it is a transitive
dependency. Missing of woodstox:wstx-asl:jar:3.2.1 leads to the failure of collecting other
dependencies such as org.apache.geronimo.framework:geronimo-kernel:jar:2.1.7 which are already
in maven central repo.
>  
> I tried applying my patch to a local copy of https://svn.apache.org/repos/asf/geronimo/devtools/eclipse-plugin/tags/geronimo-eclipse-plugin-2.2.1,
and then using "mvn clean install" to build GEP 221 with a empty local maven repository. The
build completed successfully. After build completion, I see woodstox:wstx-asl:jar:3.2.1 in
my local maven repository. So I think maybe you encountered instable network connection or
something like that during the building. BTW, my environment is: Windows XP + SUN JDK1.6.0_20
+ maven 2.2.1.
>  
> A workaround is that you may download the jar here: http://mirrors.ibiblio.org/pub/mirrors/maven/woodstox/jars/wstx-asl-3.2.1.jar,
and then using "mvn install:install-file" command to install it into you local maven repo.
After the installation, try to build GEP 221 again.

I've tried to build branches/2.2 with a clean maven repo. I'm getting the following failure:

[INFO] ------------------------------------------------------------------------          
                                                                                    
[INFO] Building org.apache.geronimo.runtime.common                                       
                                                                                    
[INFO]    task-segment: [install]                                                        
                                                                                    
[INFO] ------------------------------------------------------------------------          
                                                                                    
[INFO] [eclipsepde:manifestbundles {execution: initialize}]                              
                                                                                    
[INFO] [eclipsepde:install {execution: initialize}]                                      
                                                                                    
[INFO] [buildnumber:create {execution: default}]                                         
                                                                                    
[INFO] Storing buildNumber: 20110106103016 at timestamp: 1294327816764                   
                                                                                    
[INFO] [antrun:run {execution: backup}]                                                  
                                                                                    
[INFO] Executing tasks                                                                   
                                                                                    
     [copy] Warning: Could not find file /Users/kevan/geronimo/devtools/eclipse-plugin/branches/2.2/plugins/org.apache.geronimo.runtime.common/.classpath
to copy.            
[INFO] Executed tasks                                                                    
                                                                                    
[INFO] [dependency:copy {execution: copy}]                                               
                                                                                    
[INFO] Configured Artifact: commons-logging:commons-logging:?:jar                        
                                                                                    
[INFO] Configured Artifact: cglib:cglib-nodep:?:jar                                      
                                                                                    
[INFO] Configured Artifact: org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:?:jar   
                                                                                    
[INFO] Configured Artifact: org.apache.geronimo.specs:geronimo-jaxb_2.1_spec:?:jar       
                                                                                    
[INFO] Configured Artifact: com.sun.xml.bind:jaxb-impl:?:jar                             
                                                                                    
[INFO] Configured Artifact: org.apache.geronimo.specs:geronimo-activation_1.1_spec:?:jar 
                                                                                    
[INFO] Configured Artifact: org.apache.geronimo.specs:geronimo-javaee-deployment_1.1MR3_spec:?:jar
                                                                           
[INFO] commons-logging:commons-logging:1.0.4:jar already exists in /Users/kevan/geronimo/devtools/eclipse-plugin/branches/2.2/plugins/org.apache.geronimo.runtime.common/lib
 
[INFO] cglib:cglib-nodep:2.1_3:jar already exists in /Users/kevan/geronimo/devtools/eclipse-plugin/branches/2.2/plugins/org.apache.geronimo.runtime.common/lib
               
[INFO] org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:1.0.1:jar already exists in /Users/kevan/geronimo/devtools/eclipse-plugin/branches/2.2/plugins/org.apache.geronim\
o.runtime.common/lib                                                                     
                                                                                    
[INFO] org.apache.geronimo.specs:geronimo-jaxb_2.1_spec:1.0:jar already exists in /Users/kevan/geronimo/devtools/eclipse-plugin/branches/2.2/plugins/org.apache.geronimo.runt\
ime.common/lib                                                                           
                                                                                    
[INFO] com.sun.xml.bind:jaxb-impl:2.1.12:jar already exists in /Users/kevan/geronimo/devtools/eclipse-plugin/branches/2.2/plugins/org.apache.geronimo.runtime.common/lib
     
[INFO] org.apache.geronimo.specs:geronimo-activation_1.1_spec:1.0.2:jar already exists in
/Users/kevan/geronimo/devtools/eclipse-plugin/branches/2.2/plugins/org.apache.geron\
imo.runtime.common/lib                                                                   
                                                                                    
[INFO] org.apache.geronimo.specs:geronimo-javaee-deployment_1.1MR3_spec:1.0:jar already exists
in /Users/kevan/geronimo/devtools/eclipse-plugin/branches/2.2/plugins/org.apac\
he.geronimo.runtime.common/lib                                                           
                                                                                    
[INFO] [remote-resources:process {execution: default}]                                   
                                                                                    
[INFO] [resources:resources {execution: default-resources}]                              
                                                                                    
[INFO] Using 'UTF-8' encoding to copy filtered resources.                                
                                                                                    
[INFO] Copying 1 resource                                                                
                                                                                    
[INFO] Copying 0 resource                                                                
                                                                                    
[INFO] Copying 7 resources to lib                                                        
                                                                                    
[INFO] Copying 2 resources to META-INF                                                   
                                                                                    
[INFO] Copying 2 resources to about_files                                                
                                                                                    
[INFO] Copying 0 resource to about_files                                                 
                                                                                    
[INFO] Copying 1 resource to META-INF                                                    
                                                                                    
[INFO] [eclipsepde:validatemanifest {execution: validate-bundle-classpath}]              
                                                                                    
[INFO] ------------------------------------------------------------------------          
                                                                                    
[ERROR] BUILD ERROR                                                                      
                                                                                    
[INFO] ------------------------------------------------------------------------          
                                                                                    
[INFO] Attribute value for Bundle-Version in bundle manifest is incorrect. [Found: 2.2.1]
[Expected: 2.2.2] 
[INFO] ------------------------------------------------------------------------          
                                                                                    
[INFO] Trace                                                                             
                                                                                    
org.apache.maven.lifecycle.LifecycleExecutionException: Attribute value for Bundle-Version
in bundle manifest is incorrect. [Found: 2.2.1] [Expected: 2.2.2]                  
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
                                                               
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
                                                   
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
                                                                
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
                                               
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
                                                        
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
                                                                    
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)                
                                                                                    
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)                  
                                                                                    
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)                         
                                                                                    
        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)       
                                                                                    
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)                   
                                                                                    
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) 
                                                                                    
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                                                                             
        at java.lang.reflect.Method.invoke(Method.java:597)                              
                                                                                    
        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)           
                                                                                    
        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)                   
                                                                                    
        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)         
                                                                                    
        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)                     
                                                                                    
Caused by: org.apache.maven.plugin.MojoExecutionException: Attribute value for Bundle-Version
in bundle manifest is incorrect. [Found: 2.2.1] [Expected: 2.2.2]               
        at org.apache.geronimo.devtools.plugins.eclipsepde.ValidateManifestMojo.execute(ValidateManifestMojo.java:76)
                                                        
        at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
                                                                           
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
                                                               
        ... 17 more                                                                      
                                                                                    
Caused by: org.apache.maven.plugin.MojoFailureException: Attribute value for Bundle-Version
in bundle manifest is incorrect. [Found: 2.2.1] [Expected: 2.2.2]                 
        at org.apache.geronimo.devtools.plugins.eclipsepde.ValidateManifestMojo.validate(ValidateManifestMojo.java:109)
                                                      
        at org.apache.geronimo.devtools.plugins.eclipsepde.ValidateManifestMojo.execute(ValidateManifestMojo.java:72)
                                                        
        ... 19 more            

--kevan

Mime
View raw message