geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick McGuire <>
Subject Build problem in trunk
Date Wed, 12 Jan 2011 12:53:52 GMT
The recent wink integration changes appear to have broken trunk.  The 
wink plugin is not built by default, but the javaee6 plugin has 
dependencies on wink components.  Unfortunately, I'm getting build 
errors if I try to build the wink plugin:

[org.apache.geronimo.system.configuration.DependencyManager] : Could not 
start b
undle: org.apache.geronimo.modules.geronimo-wink-builder [104]
org.osgi.framework.BundleException: Unresolved constraint in bundle 
eronimo.modules.geronimo-wink-builder [104]: Unable to resolve 104.0: 
missing re
quirement [104.0] package; (package=org.apache.geronimo.wink) [caused 
by: Unable
  to resolve 94.0: missing requirement [94.0] package; 
.common)(version>=1.1.0)) [caused by: Unable to resolve 97.0: missing 
t [97.0] package; (&(package=org.slf4j)(version>=1.6.0))]]
         at org.apache.felix.framework.Felix.resolveBundle(
         at org.apache.felix.framework.Felix.startBundle(
         at org.apache.felix.framework.BundleImpl.start(


View raw message