geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johannes Weberhofer <jweberho...@weberhofer.at>
Subject Re: GEP version blues
Date Thu, 16 Dec 2010 10:23:24 GMT
Hello Kevan, hello Hang,

I started a discussion on that issue in March. See http://www.mail-archive.com/dev@geronimo.apache.org/msg77363.html

Unfortunately I did not have time later on to continue to do something on that issue, but
I still think, it is still an issue. I think it should always only be necessary to have one
stable and one parallel version together, whereas the stable version supports all versions
released so far.

Currently, when you install GEP in geronimo, you have to know exactly which Geronimo version
you'll develop for; At the moment you have also some stuff [G 2.1.1 (Jetty/Tomcat) Runtime,
Geronimo Core Feature] on the install-repositories which is IMHO not longer used. Additionally
there are server-adapters for Geronimo v1.0/v.1.1.x/v.2.0/v2.1/v.2.2 and v.3.0, where some
cover versions below, too, but not all.

In reality it should be enough to have a v1.1 - v.2.2 Server Adapter there (which should support
all Versions up to G 2.2 and possibly an unstable version of the adapter which supports also
the most recent development releases.

However, this would be some work which somebody would have to do... But it could also make
thinks simpler, when only a head and one stable-branch must be serviced.

Johannes

PS: Sorry for cross-posting, but I think, this thread could be discussed on the devel-mailinglist?



Am 16.12.10 06:20, schrieb han hongfang:
>
>
> On Wed, Dec 15, 2010 at 5:46 PM, KHAksnes <khaksnes@gmail.com <mailto:khaksnes@gmail.com>>
wrote:
>
>
>     My environment: Helios with Geronimo 2.1.6 and 2.2.1.
>     My problem: Which GEP version to choose?
>
>     Each version seems to have their own serious problem:
>     GEP 2.1.x doesn't support 2.2.1 as far as I know.
>     GEP 2.2 have problems editing openejb-jar.xml
>
> For this problem, can you open a JIRA in https://issues.apache.org/jira/browse/GERONIMODEVTOOLS,
and describe the problem details. So it can be considerred in GEP 2.2.1 release.
>
>     GEP 3.0 fails to deploy EARs to Geronimo 2.2.1
>
>     The obvious solution is likely to be GEP 2.2.1. but unfortunately it isn't
>     released yet.
>
>     We started a project this summer using Geronimo 2.2 but had to switch to
>     2.1.x due to a couple of serious bugs in 2.2. Now when 2.2.1 is out we wan't
>     to switch to it checking for compatibility etc. To ease this process we need
>     support for both 2.1.6 and 2.2.1 in the same environment.
>     --
>     View this message in context: http://apache-geronimo.328035.n3.nabble.com/GEP-version-blues-tp2091121p2091121.html
>     Sent from the Users mailing list archive at Nabble.com.
>
>
>
>
> --
> Best regards,
>
> Han Hong Fang (Janet)
> hanhongfang AT apache.org <http://apache.org/>
>

-- 
Johannes Weberhofer
Weberhofer GmbH, Austria, Vienna

Mime
View raw message