geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: activemq-jetty-server
Date Wed, 08 Dec 2010 18:02:58 GMT
This is easy to fix, although I don't recall the exact fix at the moment.  j2ee-system is getting
installed twice, once from a mvn url and once from a non-maven url.  Since the mvn url seems
to have gotten installed first the trick is to figure out why the dependency manager is trying
to use a non-mvn url.  Maybe the flag saying what kind of url to use got set wrong somehow.
 This should be reasonably possible to debug since this is about the first geronimo bundle
that gets installed.  

thanks
david jencks

On Dec 8, 2010, at 7:40 AM, Rick McGuire wrote:

> Continuing on with trying to get a clean build using -Pall-subprojects.  Now I'm getting
a strange error attempting to build the activemq-jetty-server.  The created assembly will
not start with the following errors:
> 
> 2010-12-08 10:16:01,654 DEBUG [prefs] ServiceEvent REGISTERED
> 2010-12-08 10:16:01,967 INFO  [geronimo-osgi-registry] SPI-Provider Manifest header found
in bundle: org.apache.geronimo.bundles.woodstox
> 2010-12-08 10:16:02,170 INFO  [geronimo-osgi-registry] SPI-Provider Manifest header found
in bundle: org.apache.geronimo.bundles.jaxb-impl
> 2010-12-08 10:16:02,264 INFO  [AbstractGBeanReference] GBean references are not using
proxies
> 2010-12-08 10:16:02,451 INFO  [SecurityUtils] BouncyCastle not registered, using the
default JCE provider
> 2010-12-08 10:16:02,514 INFO  [BasicServerInfo] Runtime Information:
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   Install directory = C:\g-3.0\plugins\activemq\activemq-jetty-server\target\activemq-jetty-server-3.0-SNAPSHOT
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   Server directory  = C:\g-3.0\plugins\activemq\activemq-jetty-server\target\activemq-jetty-server-3.0-SNAPSHOT
> 2010-12-08 10:16:02,561 INFO  [JvmVendor] Sun JVM 1.6.0_21
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   JVM in use        = Sun JVM 1.6.0_21
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo] Java Information:
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.runtime.name]
    = Java(TM) SE Runtime Environment
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.runtime.version]
 = 1.6.0_21-b06
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [os.name]         
     = Windows XP
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [os.version]      
     = 5.1
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [sun.os.patch.level]
   = Service Pack 3
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [os.arch]         
     = x86
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.class.version]
   = 50.0
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [locale]          
     = en_US
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [unicode.encoding]
     = UnicodeLittle
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [file.encoding]   
     = Cp1252
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.vm.name]    
     = Java HotSpot(TM) Client VM
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.vm.vendor]  
     = Sun Microsystems Inc.
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.vm.version] 
     = 17.0-b16
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.vm.info]    
     = mixed mode
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.home]       
     = C:\java\jdk1.6.0_21\jre
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.classpath]  
     = null
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.library.path]
    = C:\java\jdk1.6.0_21\jre\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program
Files\IBM\Infoprint Select;C:\Notes;C:\Program Files\XLView;C:\lotus\compnent;C:\Utilities;C:\Program
Files\Common Files\Lenovo;C:\program files\ibm\personal communications\;C:\Program Files\IBM\Trace
Facility\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\ThinkPad\ConnectUtilities;C:\Program
Files\ooRexx;C:\Program Files\SlikSvn\bin\;C:\Program Files\SlickEditV15.0.0\win\;c:\Program
Files\GNU\GnuPG;C:\Program Files\SlickEditV14.0.2\win\;C:\Java\jdk1.6.0_16\jre\bin;C:\Java\jdk1.6.0_21\bin;c:\Program
Files\apache-ant-1.7.0\bin;c:\Program Files\Apache Software Foundation\maven-2.2.1\bin;c:\cygwin\bin;
;C:\Program Files\CVS Suite\CVSNT Tools\
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.endorsed.dirs]
   = C:\g-3.0\plugins\activemq\activemq-jetty-server\target\activemq-jetty-server-3.0-SNAPSHOT\lib\endorsed;C:\java\jdk1.6.0_21\jre\lib\endorsed
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [java.ext.dirs]   
     = C:\g-3.0\plugins\activemq\activemq-jetty-server\target\activemq-jetty-server-3.0-SNAPSHOT\lib\ext;C:\java\jdk1.6.0_21\jre\lib\ext;C:\WINDOWS\Sun\Java\lib\ext
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo]   System property [sun.boot.class.path]
  = C:\g-3.0\plugins\activemq\activemq-jetty-server\target\activemq-jetty-server-3.0-SNAPSHOT\lib\endorsed\yoko-rmi-spec.jar;C:\g-3.0\plugins\activemq\activemq-jetty-server\target\activemq-jetty-server-3.0-SNAPSHOT\lib\endorsed\yoko-spec-corba.jar;C:\java\jdk1.6.0_21\jre\lib\resources.jar;C:\java\jdk1.6.0_21\jre\lib\rt.jar;C:\java\jdk1.6.0_21\jre\lib\sunrsasign.jar;C:\java\jdk1.6.0_21\jre\lib\jsse.jar;C:\java\jdk1.6.0_21\jre\lib\jce.jar;C:\java\jdk1.6.0_21\jre\lib\charsets.jar;C:\java\jdk1.6.0_21\jre\classes
> 2010-12-08 10:16:02,561 INFO  [BasicServerInfo] ----------------------------------------------
> 2010-12-08 10:16:03,936 WARN  [DependencyManager] Could not install bundle for artifact:
org.apache.geronimo.framework/j2ee-system/3.0-SNAPSHOT/car
> org.eclipse.osgi.framework.internal.core.Framework$DuplicateBundleException: Bundle "org.apache.geronimo.framework.j2ee-system"
version "3.0.0.SNAPSHOT" has already been installed from: mvn:org.apache.geronimo.framework/j2ee-system/3.0-SNAPSHOT/car
>        at org.eclipse.osgi.framework.internal.core.Framework.createAndVerifyBundle(Framework.java:714)
>        at org.eclipse.osgi.framework.internal.core.Framework.installWorkerPrivileged(Framework.java:922)
>        at org.eclipse.osgi.framework.internal.core.Framework$1.run(Framework.java:837)
>        at java.security.AccessController.doPrivileged(Native Method)
>        at org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.java:888)
>        at org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.java:832)
>        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:167)
>        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:161)
>        at org.apache.geronimo.system.configuration.DependencyManager.installed(DependencyManager.java:289)
>        at org.apache.geronimo.system.configuration.DependencyManager.bundleChanged(DependencyManager.java:122)
>        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.dispatchEvent(BundleContextImpl.java:919)
>        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>        at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:149)
>        at org.eclipse.osgi.framework.internal.core.Framework.publishBundleEventPrivileged(Framework.java:1349)
>        at org.eclipse.osgi.framework.internal.core.Framework.publishBundleEvent(Framework.java:1300)
>        at org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.java:889)
>        at org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.java:832)
>        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:167)
>        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:161)
>        at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(SimpleConfigurationManager.java:300)
>        at org.apache.geronimo.system.main.EmbeddedDaemon.doStartup(EmbeddedDaemon.java:195)
>        at org.apache.geronimo.system.main.EmbeddedDaemon.execute(EmbeddedDaemon.java:91)
>        at org.apache.geronimo.system.osgi.BootActivator$1.execute(BootActivator.java:107)
>        at org.apache.geronimo.main.Bootstrapper.execute(Bootstrapper.java:65)
>        at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:65)
>        at org.apache.geronimo.cli.daemon.DaemonCLI.main(DaemonCLI.java:32)
> 
> 
> Similar exceptions are getting thrown for all of the core server bundles.  It looks like
somehow all of the bundles are getting installed twice, but I'm not spotting any obvious cause
for this.  For the 3.0-M1 release, the activemq-jetty-server was one of the delete components,
so perhaps the best solution at this point would be to remove it from the all-subprojects
list, unless fixing this build error is a simple process.
> 
> Rick


Mime
View raw message