Hi Forrest,

I've been wondering what to do about this situation.  One idea I had was to:

1. make a tranql jar including the missing ClientException class and any others needed.  I would not make this a bundle
2. include this jar in each tranql rar.  This will get it in the same classloader as the other tranql jars in any connector container.
3. hopefully the result will work on both java 5 and java 6. 

If this doesn't work I suspect we will have to roll back the upgrade to java 6 and I'll have to figure out how to build on java 5 again.

thanks!
david jencks

On Nov 8, 2010, at 6:46 PM, Forrest Xia wrote:

Hi David,

I want to give a hand on tranql java 5 incompatible issue, my basic idea is to make a java 5 compatible build with the necessary fixes for G 2.1.7 release use.

Can you give me some guideline or comments on this?

Thank you!

Forrest

On Wed, Nov 3, 2010 at 9:20 AM, David Jencks <david_jencks@yahoo.com> wrote:
I"ve modified the tranql connectors to build under java 1.6 and pushed snapshots
to nexus.codehaus.org.

If anyone has java 1.5 and a few minutes I'd really like to find out if these
work on java 1.5.

You can find them as the latest snapshots under
https://nexus.codehaus.org/content/groups/snapshots-group/org/tranql/

thanks!
david jencks