geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From viola lu <viola...@gmail.com>
Subject Re: [Discussion] Upgrade org.eclipse.osgi from 3.5.1.v20090827 to 3.6.0
Date Wed, 17 Nov 2010 10:22:34 GMT
Thanks. but i found there is only a karaf-jaas-boot.jar which already under
lib/ folder, no karaf-boot.jar. I also downloaded a
apache-karaf-2.1.1.zip, i only found a karaf-jaas-boot.jar, no
karaf-boot.jar:(. Where can i find karaf-boot.jar?
Thanks in advance!
On Wed, Nov 17, 2010 at 6:07 PM, Guillaume Nodet <gnodet@gmail.com> wrote:

> We have a problem with 2.1.1 and we will roll out a karaf 2.1.2 this
> week or next.
> A simple workaround is to change the startup script so that
> karaf-boot.jar is included in the boot classpath.
>
> On Wed, Nov 17, 2010 at 10:59, viola lu <viola.lu@gmail.com> wrote:
> > Thanks Rex and Shawn.
> > I tried to upgrade karaf and org.eclipse.osgi as below:
> > framework/pom.xml
> >  <dependency>
> >                 <groupId>org.eclipse</groupId>
> >                 <artifactId>osgi</artifactId>
> >                 <version>3.6.0.v20100517</version>
> >             </dependency>
> > framework/config/karaf-framework/pom.xml
> >  <karaf.osgi.version>2.1.1</karaf.osgi.version>
> > <equinox.version>3.6.0.v20100517</equinox.version>
> > Build successfully, but fail to login admin console. "Invalid
> > username/password".:(
> > Working on why this happened.
> > On Wed, Nov 17, 2010 at 11:28 AM, Rex Wang <rwonly@gmail.com> wrote:
> >>
> >> I prefer to update karaf to 2.2.1 and together with equinox
> >> 3.6.0.v20100517...
> >>
> >> 2010/11/17 viola lu <viola.lu@gmail.com>
> >>>
> >>> Hi, Dev:
> >>>  When i fix the jira
> https://issues.apache.org/jira/browse/GERONIMO-5615,
> >>> found that it's a bug in org.eclipse.osgi v3.5 which cann't support
> bundle
> >>> file path containing %20 instead of space very well.From eclipse
> bugzillia
> >>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=290193, eclipse 3.6 has
> >>> already fixed this problem. So post here to get your feedback about
> whether
> >>> it's ok to upgrade org.eclipse.osgi from 3.5.1.v20090827 to 3.6? I
> already
> >>> opened a jira: https://issues.apache.org/jira/browse/GERONIMO-5699 to
> track
> >>> this upgrade problem, if upgrade is OK, i will upload a patch for it.
> >>> Appreciate your response!
> >>>
> >>> --
> >>> viola
> >>
> >>
> >>
> >> --
> >> Lei Wang (Rex)
> >> rwonly AT apache.org
> >
> >
> >
> > --
> > viola
> >
>
>
>
> --
> Cheers,
> Guillaume Nodet
> ------------------------
> Blog: http://gnodet.blogspot.com/
> ------------------------
> Open Source SOA
> http://fusesource.com
>



-- 
viola

Mime
View raw message