geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "maojia (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-5579) Problem with "deploy:connect" gogo command
Date Fri, 19 Nov 2010 06:50:13 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-5579?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12933701#action_12933701
] 

maojia commented on GERONIMO-5579:
----------------------------------

I tried the case again with a new geronimo-tomcat7-javaee6-3.0-SNAPSHOT-bin server built on
11/17/2010 and got the following error:

geronimo> deploy:connect -p 1109
Connecting to Geronimo server: localhost:1109
Username: system
Password: *******
Error executing command: Unable to connect to server at deployer:geronimo:jmx://
localhost:1109 -- Failed to retrieve RMIServer stub: javax.naming.ConfigurationE
xception: rmiURLContextFactory.getObjectInstance: argument must be an RMI URL St
ring or an array of them 


> Problem with "deploy:connect" gogo command
> ------------------------------------------
>
>                 Key: GERONIMO-5579
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5579
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: commands
>    Affects Versions: 3.0
>         Environment: windows platform 
>            Reporter: maojia
>            Assignee: Ivan
>            Priority: Minor
>             Fix For: 3.0
>
>         Attachments: GERONIMO-5579.patch
>
>
> I started two server instances on my local Windows platform:
> geronimo-tomcat7-javaee6-3.0-SNAPSHOT     using port 1099,started with the "run Geronimo"
command;
> geronimo-tomcat6-javaee5-2.2       using port 1109, started with the "startup"command.
> On the karaf shell for the geronimo-tomcat7-javaee6-3.0-SNAPSHOT  server:
> I ran the "deploy:connect --port 1109"command trying to connect the geronimo-tomcat6-javaee5-2.2
server. "Connection established"was displayed. 
> However,when running the "deploy:list-modules"command, it was the modules belonging to
the geronimo-tomcat7-javaee6-3.0-SNAPSHOT server that was listed, indicating that it was still
the 
> geronimo-tomcat7-javaee6-3.0-SNAPSHOT server that was connected.
> The information on the command window is as follows:
> geronimo> deploy:disconnect
> Not connected
> geronimo> deploy:connect --hostname localhost --port 1109
> Connection established
> geronimo> deploy:list-modules
> Found 54 modules
>   + org.apache.geronimo.configs/activemq-broker-blueprint/3.0-SNAPSHOT/car
>   + org.apache.geronimo.configs/activemq-ra/3.0-SNAPSHOT/car
>   + org.apache.geronimo.configs/aries-deployer/3.0-SNAPSHOT/car
>   + org.apache.geronimo.configs/axis2-deployer/3.0-SNAPSHOT/car
>   + org.apache.geronimo.configs/bval-deployer/3.0-SNAPSHOT/car
>   + org.apache.geronimo.configs/client-deployer/3.0-SNAPSHOT/car
>  .......

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message