geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vamsavardhana Reddy <c1vams...@gmail.com>
Subject Re: Bean Validation problems in trunk.
Date Thu, 14 Oct 2010 02:33:47 GMT
On Wed, Oct 13, 2010 at 11:47 PM, Rick McGuire <rickmcg@gmail.com> wrote:

>  The recent changes to the bean validation support appear to be causing
> failures in both the TCK and the bean validation testsuite.  I've tried to
> do a little problem determination, but I think Vamsi is probably going to
> need to take a look at this.  In the testsuite failures, it looks to me that
> the validation factory configuration is not getting set up correctly so that
> not all of the constraints are getting applied in the tests.  Many of the
> failures are just using the default constraint classes.
>
I see that only those constraint classes that are within the  same test
project are being used in the validation, but the default ones are not.  I
will take a look at what is happening.


> In the TCK, I'm seeing a lot of the same failures where the test was
> expecting constraint failures and not getting any, so this is probably the
> same thing.
>
> There's at least one other problem with the TCK.  A number of tests are
> getting deploy failures because of errors with the validation.xml.  Since
> these tests actually ARE tests for the invalid XML. this suggests that any
> parsing errors discovered at deploy time should not be terminal.
>
hmm...  I will change the deployment exceptions to log warning messages
instead.



>
> Rick
>



-- 
Vamsi

Mime
View raw message