geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Kirby (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-673) Don't download TPTP runtime since maven-eclipsepde-plugin 1.1 can handle optional bundle now
Date Sun, 24 Oct 2010 14:52:21 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-673?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12924320#action_12924320
] 

Ted Kirby commented on GERONIMODEVTOOLS-673:
--------------------------------------------

I question this change on two grounds:

1. I get these two errors in eclipse:

Description	Resource	Path	Location	Type
Unknown extension point: 'org.eclipse.hyades.trace.ui.launchConfigMechanismAssociator'	plugin.xml
/org.apache.geronimo.st.core	line 178	Plug-in Problem

Description	Resource	Path	Location	Type
Unknown extension point: 'org.eclipse.hyades.trace.ui.launchConfigMechanismAssociator'	plugin.xml
/org.apache.geronimo.st.v30.core	line 351	Plug-in Problem

Note the tptp references in org.apache.geronimo.st.core/plugin.xml:

<extension
       point="org.eclipse.hyades.trace.ui.launchConfigMechanismAssociator">
       <association            
           launchConfigID = "org.apache.geronimo.st.core.launchConfigurationType">
   
           <mechanism mechanismID = "org.eclipse.tptp.trace.ui.jvmpiMechanism"> 
               <configuration
                   launchDelegate = "org.eclipse.tptp.trace.ui.internal.launcher.deleg.application.PIAttachLauncherDelegate"
                   configurationId = "org.eclipse.tptp.trace.ui.jvmpiConfiguration"
                   associatedAgent = "org.eclipse.tptp.trace.ui.jvmpiAgent"        
                   filter = "org.eclipse.tptp.platform.profile.server.core.internal.PICollectorFiltration">
               
               </configuration>            
           </mechanism>        
           
           <mechanism mechanismID = "org.eclipse.tptp.trace.jvmti.jvmtiMechanism"> 
               <configuration
                   launchDelegate = "org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIAttachLauncherDelegate"
                   configurationId = "org.eclipse.tptp.trace.jvmti.tiConfiguration"
                   associatedAgent = "org.eclipse.tptp.platform.jvmti.TIAgent"
                   filter = "org.eclipse.tptp.platform.profile.server.core.internal.TICollectorFiltration">
                           
               </configuration>            
           </mechanism>    
       </association>
   </extension>

Does org.eclipse.hyades come from TPTP?

2.  The test suite fails here:

windows:
     [echo] Launching Equinox with -Dos=win32 -Dws=win32 -Darch=x86
     [java] Buildfile: testsuite.xml
     [java]
     [java] all:
     [java]
     [java] testsuite.v30:
     [java]
     [java] junit:
     [java]
     [java] init:
     [java]
     [java] suite:
     [java]     [mkdir] Created dir: C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\eclipse\e
clipse\jdt_folder\src
     [java]      [copy] Copying 36 files to C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\ec
lipse\eclipse\jdt_folder\src
     [java]
     [java] init:
     [java]     [mkdir] Created dir: C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\results\j
unit
     [java]
     [java] ui-test:
     [java]
     [java] java-test:
     [java]      [echo] Running org.apache.geronimo.testsuite.v30.ui.EclipseUITest. Result
file: C:\
svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher/results/junit/org.apache.geronimo.testsuite.v30.u
i.EclipseUITest.xml.
     [java]      [java] abbot.swt.finder.generic.NotFoundException
     [java]      [java]         at abbot.swt.finder.generic.FinderImpl.found(FinderImpl.java:74)
     [java]      [java]         at abbot.swt.finder.generic.FinderImpl.find(FinderImpl.java:65)
     [java]      [java]         at org.apache.geronimo.testsuite.common.ui.AbbotHelper.rightClickIte
m(AbbotHelper.java:131)
     [java]      [java]         at org.apache.geronimo.testsuite.common.ui.ServerTasks.startServer(S
erverTasks.java:100)
     [java]      [java]         at org.apache.geronimo.testsuite.v30.ui.EclipseUITest.installServer(
EclipseUITest.java:94)
     [java]      [java]         at org.apache.geronimo.testsuite.v30.ui.EclipseUITest.testEclipseUI(
EclipseUITest.java:65)
     [java]      [java]         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     [java]      [java]         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorI
mpl.java:39)
     [java]      [java]         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodA
ccessorImpl.java:25)
     [java]      [java]         at java.lang.reflect.Method.invoke(Method.java:597)
     [java]      [java]         at junit.framework.TestCase.runTest(TestCase.java:168)
     [java]      [java]         at junit.framework.TestCase.runBare(TestCase.java:134)
     [java]      [java]         at abbot.swt.junit.extensions.SWTTestCase.runBareWrapper(SWTTestCase
.java:278)
     [java]      [java]         at abbot.swt.junit.extensions.SWTTestCase.access$2(SWTTestCase.java:
275)
     [java]      [java]         at abbot.swt.junit.extensions.SWTTestCase$4.execute(SWTTestCase.java
:252)
     [java]      [java]         at abbot.swt.junit.extensions.UserThread.run(UserThread.java:75)
     [java]
     [java] BUILD FAILED
     [java] C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\testsuite.xml:72: The following
er
ror occurred while executing this line:
     [java] C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\testsuite.xml:56: The following
er
ror occurred while executing this line:
     [java] C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\testsuite.xml:38: The following
er
ror occurred while executing this line:
     [java] C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\testsuite.xml:46: The following
er
ror occurred while executing this line:
     [java] C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\eclipse\eclipse\plugins\org.apache
.geronimo.testsuite.v30-3.0.0\test.xml:79: The following error occurred while executing this
line:
     [java] C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\plugins\org.apache.geronimo.testsuite.commo
n\library.xml:74: The following error occurred while executing this line:
     [java] C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\plugins\org.apache.geronimo.testsuite.commo
n\library.xml:89: Java returned: 2
     [java]
     [java] Total time: 2 minutes 23 seconds
     [java] An error has occurred. See the log file
     [java] C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\workspace\.metadata\.log.
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] An Ant BuildException has occured: The following error occurred while executing this
line:
C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\build.xml:107: The following error occurred
wh
ile executing this line:
C:\svn\gdvtls\eclipse-plugin\trunk\testsuite\launcher\build.xml:83: Java returned: 13

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 52 minutes 54 seconds
[INFO] Finished at: Fri Oct 22 14:14:04 EDT 2010
[INFO] Final Memory: 341M/989M
[INFO] ------------------------------------------------------------------------

In this code:

public boolean startServer (boolean restart) {
        boolean success = true;
        try {
            String serverDisplay = Constants.getConstant(serverVersion, Constants.SERVERDISPLAY);
            abbotHelper.clickMenuItem (workbenchShell,
                    new String[] {"&Window", "Show View", "Servers"});

            if (restart == true) {
                abbotHelper.rightClickItem (workbenchShell, serverDisplay,
                        new String[] {"&Restart"});
            } else {
                abbotHelper.rightClickItem (workbenchShell, serverDisplay,
                        new String[] {"&Start"});

>From watching it run, it looks like there is no server.
 
It looks like TPTP is needed to run the testsuite, to launch a server, as suggested by the
above plugin.xml.  Is this the case?

It is possible that TPTP need only be downloaded in testsuite/eclipse/build.xml for this issue,
but issue 1 is mainline.

Comments?  Explanations?


> Don't download TPTP runtime since maven-eclipsepde-plugin 1.1 can handle optional bundle
now
> --------------------------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-673
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-673
>             Project: Geronimo-Devtools
>          Issue Type: Improvement
>          Components: eclipse-plugin
>    Affects Versions: 3.0
>            Reporter: Delos Dai
>            Assignee: Delos Dai
>             Fix For: 3.0
>
>         Attachments: GERONIMODEVTOOLS-673 .patch
>
>
> From 2.1.6, building GEP will download TPTP runtime from eclipse site. In fact, it's
not necessary now, since maven-eclipsepde-plugin 1.1 has been updated and we don't have to
download optional bundle such as plugins in TPTP runtime.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message