geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Kirby (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-675) GEP TestSuite not working in 3.0 trunk
Date Thu, 07 Oct 2010 19:12:31 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-675?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12919025#action_12919025
] 

Ted Kirby commented on GERONIMODEVTOOLS-675:
--------------------------------------------

In rev 1005580, I got a *lot* further.  There, I tweaked a couple of pom versions to get things
rolling.

Now, I get missing artifacts.  On the Mac, I get 7 missing artifacts:


[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve dependencies for one or more projects in the reactor. Reason: Missing:
----------
1) org.directwebremoting:dwr:jar:2.0.5

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=org.directwebremoting -DartifactId=dwr -Dversion=2.0.5
-Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=org.directwebremoting -DartifactId=dwr -Dversion=2.0.5
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency: 
  	1) org.apache.geronimo.devtools:testsuite:pom:3.0.0
  	2) org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1.4
  	3) org.apache.geronimo.plugins:console-tomcat:car:2.1.4
  	4) org.directwebremoting:dwr:jar:2.0.5

2) org.apache.axis2:axis2-jaxws:jar:1.3-G20090325

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=org.apache.axis2 -DartifactId=axis2-jaxws -Dversion=1.3-G20090325
-Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=org.apache.axis2 -DartifactId=axis2-jaxws -Dversion=1.3-G20090325
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency: 
  	1) org.apache.geronimo.devtools:testsuite:pom:3.0.0
  	2) org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1.4
  	3) org.apache.geronimo.configs:axis2:car:2.1.4
  	4) org.apache.axis2:axis2-jaxws:jar:1.3-G20090325

3) org.apache.activemq:activemq-core:jar:4.1.2-G20090207

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=org.apache.activemq -DartifactId=activemq-core -Dversion=4.1.2-G20090207
-Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=org.apache.activemq -DartifactId=activemq-core -Dversion=4.1.2-G20090207
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency: 
  	1) org.apache.geronimo.devtools:testsuite:pom:3.0.0
  	2) org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1.4
  	3) org.apache.geronimo.configs:activemq-broker:car:2.1.4
  	4) org.apache.activemq:activemq-core:jar:4.1.2-G20090207

4) org.apache.axis2:axis2-kernel:jar:1.3-G20090325

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=org.apache.axis2 -DartifactId=axis2-kernel -Dversion=1.3-G20090325
-Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=org.apache.axis2 -DartifactId=axis2-kernel -Dversion=1.3-G20090325
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency: 
  	1) org.apache.geronimo.devtools:testsuite:pom:3.0.0
  	2) org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1.4
  	3) org.apache.geronimo.configs:axis2:car:2.1.4
  	4) org.apache.axis2:axis2-kernel:jar:1.3-G20090325

5) org.apache.tomcat:jasper-el:jar:6.0.18-G678601

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=org.apache.tomcat -DartifactId=jasper-el -Dversion=6.0.18-G678601
-Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=org.apache.tomcat -DartifactId=jasper-el -Dversion=6.0.18-G678601
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency: 
  	1) org.apache.geronimo.devtools:testsuite:pom:3.0.0
  	2) org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1.4
  	3) org.apache.geronimo.configs:jasper:car:2.1.4
  	4) org.apache.tomcat:jasper-el:jar:6.0.18-G678601

6) org.apache.axis2:axis2-metadata:jar:1.3-G20090325

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=org.apache.axis2 -DartifactId=axis2-metadata -Dversion=1.3-G20090325
-Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=org.apache.axis2 -DartifactId=axis2-metadata -Dversion=1.3-G20090325
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency: 
  	1) org.apache.geronimo.devtools:testsuite:pom:3.0.0
  	2) org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1.4
  	3) org.apache.geronimo.configs:axis2:car:2.1.4
  	4) org.apache.axis2:axis2-metadata:jar:1.3-G20090325

7) org.apache.axis2:axis2-saaj:jar:1.3-G20090325

  Try downloading the file manually from the project website.

  Then, install it using the command: 
      mvn install:install-file -DgroupId=org.apache.axis2 -DartifactId=axis2-saaj -Dversion=1.3-G20090325
-Dpackaging=jar -Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file there: 
      mvn deploy:deploy-file -DgroupId=org.apache.axis2 -DartifactId=axis2-saaj -Dversion=1.3-G20090325
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency: 
  	1) org.apache.geronimo.devtools:testsuite:pom:3.0.0
  	2) org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.1.4
  	3) org.apache.geronimo.configs:axis2:car:2.1.4
  	4) org.apache.axis2:axis2-saaj:jar:1.3-G20090325

----------
7 required artifacts are missing.

for artifact: 
  org.apache.geronimo.devtools:testsuite:pom:3.0.0

from the specified remote repositories:
  apache.snapshots (http://repository.apache.org/snapshots),
  releases.openqa.org (http://archiva.openqa.org/repository/releases),
  central (http://repo1.maven.org/maven2),
  java.net (http://download.java.net/maven/1/),
  codehaus-snapshots (http://snapshots.repository.codehaus.org),
  snapshots.openqa.org (http://archiva.openqa.org/repository/snapshots),
  apache-snapshots (https://repository.apache.org/content/groups/snapshots-group),
  geronimo-server-trunk (https://svn.apache.org/repos/asf/geronimo/server/trunk/repository/),
  geronimo-server-2.0.2 (https://svn.apache.org/repos/asf/geronimo/server/tags/2.0.2/repository/)


> GEP TestSuite not working in 3.0 trunk
> --------------------------------------
>
>                 Key: GERONIMODEVTOOLS-675
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-675
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 3.0
>            Reporter: Ted Kirby
>            Assignee: Delos Dai
>             Fix For: 3.0
>
>
> ~/svn/gdvtls/eclipse-plugin/trunk $ mvn clean install -Ptestsuite
> [INFO] Scanning for projects...
> [INFO] ------------------------------------------------------------------------
> [ERROR] FATAL ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error building POM (may not be this project's POM).
> Project ID: org.apache.geronimo.devtools:testsuite:pom:3.0.0
> Reason: Cannot find parent: org.apache.geronimo.devtools:geronimo-eclipse-plugin for
project: org.apache.geronimo.devtools:testsuite:pom:3.0.0 for project org.apache.geronimo.devtools:testsuite:pom:3.0.0
> [INFO] ------------------------------------------------------------------------
> [INFO] Trace
> org.apache.maven.reactor.MavenExecutionException: Cannot find parent: org.apache.geronimo.devtools:geronimo-eclipse-plugin
for project: org.apache.geronimo.devtools:testsuite:pom:3.0.0 for project org.apache.geronimo.devtools:testsuite:pom:3.0.0
> 	at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:404)
> 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:272)
> 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
> 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
> 	at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> 	at java.lang.reflect.Method.invoke(Method.java:597)
> 	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
> 	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
> 	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
> 	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.project.ProjectBuildingException: Cannot find parent: org.apache.geronimo.devtools:geronimo-eclipse-plugin
for project: org.apache.geronimo.devtools:testsuite:pom:3.0.0 for project org.apache.geronimo.devtools:testsuite:pom:3.0.0
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1396)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:823)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:508)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:200)
> 	at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:604)
> 	at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:487)
> 	at org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:560)
> 	at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:391)
> 	... 12 more
> Caused by: org.apache.maven.project.ProjectBuildingException: POM 'org.apache.geronimo.devtools:geronimo-eclipse-plugin'
not found in repository: Unable to download the artifact from any repository
>   org.apache.geronimo.devtools:geronimo-eclipse-plugin:pom:3.0_M1-SNAPSHOT
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   geronimo-server-trunk (https://svn.apache.org/repos/asf/geronimo/server/trunk/repository/),
>   geronimo-server-2.0.2 (https://svn.apache.org/repos/asf/geronimo/server/tags/2.0.2/repository/)
>  for project org.apache.geronimo.devtools:geronimo-eclipse-plugin
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:605)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1392)
> 	... 19 more
> Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download
the artifact from any repository
>   org.apache.geronimo.devtools:geronimo-eclipse-plugin:pom:3.0_M1-SNAPSHOT
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   geronimo-server-trunk (https://svn.apache.org/repos/asf/geronimo/server/trunk/repository/),
>   geronimo-server-2.0.2 (https://svn.apache.org/repos/asf/geronimo/server/tags/2.0.2/repository/)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:228)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:90)
> 	at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:558)
> 	... 20 more
> Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to download the
artifact from any repository
> 	at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:404)
> 	at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:216)
> 	... 22 more
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 3 seconds
> [INFO] Finished at: Thu Oct 07 11:15:55 EDT 2010
> [INFO] Final Memory: 8M/507M
> [INFO] ------------------------------------------------------------------------

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message