geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lu Jiang (JIRA)" <j...@apache.org>
Subject [jira] Closed: (GERONIMO-5298) Bad version information in deployment plan will result in deploy failure
Date Thu, 19 Aug 2010 08:29:16 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-5298?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Lu Jiang closed GERONIMO-5298.
------------------------------


Fixed after verification,so close it.

> Bad version information in deployment plan will result in deploy failure
> ------------------------------------------------------------------------
>
>                 Key: GERONIMO-5298
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5298
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: deployment
>    Affects Versions: 3.0
>         Environment: OS:WIN XP SP2
> Server:Geronimo 3.0-SNAPSHOT 2010.5.6 build
> JDK:1.6
>            Reporter: Lu Jiang
>            Assignee: Ivan
>             Fix For: 3.0
>
>         Attachments: geronimo-web.xml, hello.war
>
>
> I tried to deploy a simple helloworld web application.(see attach file for hello.war),using
the deploy plan below:
> <?xml version="1.0" encoding="UTF-8"?>
> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1" 
>          xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.2" 
>          xmlns:sec="http://geronimo.apache.org/xml/ns/security-2.0" 
>          xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.2">   
>   <sys:environment>
>     <sys:moduleId>
>       <sys:groupId>org.apache.geronimo.samples</sys:groupId>
>       <sys:artifactId>hello</sys:artifactId>
>       <sys:version>2.1.1.4</sys:version>
>       <sys:type>car</sys:type>
>     </sys:moduleId>
>     <sys:dependencies/>
>     <sys:hidden-classes/>
>     <sys:non-overridable-classes/>
>   </sys:environment> 
>   <context-root>/hello</context-root>
> </web-app>
> Deployment will fail with an exception:
> Unable to create configuration for deployment: dependencies: null
> org.apache.geronimo.common.DeploymentException: Unable to create configuration for deployment:
dependencies: null
> 	at org.apache.geronimo.deployment.DeploymentContext.createTempConfiguration(DeploymentContext.java:208)
> 	at org.apache.geronimo.deployment.DeploymentContext.initializeConfiguration(DeploymentContext.java:188)
> 	at org.apache.geronimo.j2ee.deployment.EARConfigBuilder.buildConfiguration(EARConfigBuilder.java:606)
> 	at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:250)
> 	at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:138)
> 	at sun.reflect.GeneratedMethodAccessor214.invoke(Unknown Source)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> 	at java.lang.reflect.Method.invoke(Method.java:597)
> 	at org.apache.geronimo.gbean.runtime.ReflectionMethodInvoker.invoke(ReflectionMethodInvoker.java:34)
> 	at org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(GBeanOperation.java:131)
> 	at org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(GBeanInstance.java:856)
> 	at org.apache.geronimo.kernel.basic.BasicKernel.invoke(BasicKernel.java:245)
> 	at org.apache.geronimo.deployment.plugin.local.AbstractDeployCommand.doDeploy(AbstractDeployCommand.java:116)
> 	at org.apache.geronimo.deployment.plugin.local.DistributeCommand.run(DistributeCommand.java:61)
> 	at java.lang.Thread.run(Thread.java:619)
> Caused by: org.osgi.framework.BundleException: Could not create bundle object.
> 	at org.apache.felix.framework.Felix.installBundle(Felix.java:2487)
> 	at org.apache.felix.framework.Felix.installBundle(Felix.java:2334)
> 	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:130)
> 	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:108)
> 	at org.apache.geronimo.deployment.DeploymentContext.createTempConfiguration(DeploymentContext.java:200)
> 	... 14 more
> Caused by: java.lang.IllegalArgumentException: invalid format
> 	at org.osgi.framework.Version.(Version.java:140)
> 	at org.osgi.framework.Version.parseVersion(Version.java:218)
> 	at org.apache.felix.framework.util.manifestparser.ManifestParser.(ManifestParser.java:76)
> 	at org.apache.felix.framework.ModuleImpl.(ModuleImpl.java:221)
> 	at org.apache.felix.framework.BundleImpl.createModule(BundleImpl.java:1121)
> 	at org.apache.felix.framework.BundleImpl.(BundleImpl.java:79)
> 	at org.apache.felix.framework.Felix.installBundle(Felix.java:2429)
> 	... 18 more
> The strange thing is if I change version information in the deploy plan to "2","2.1","2.1.1"
or "3.0-SNAPSHOT" etc. Deployment process will succeed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message