geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "viola.lu (JIRA)" <j...@apache.org>
Subject [jira] Updated: (GERONIMO-5495) Upgrade the geronimo-openejb-2.0.xsd file for new persistence schema
Date Thu, 12 Aug 2010 08:28:16 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-5495?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

viola.lu updated GERONIMO-5495:
-------------------------------

    Attachment: G-5495.patch

Pls review it, thanks in advance!
Here i changed openejb persistence.setversion("1.0") to 2.0 and xsd file.Now errors in jira
5509 disappear.
For web module, there is already convertPersistenceSchemaVersion function to covert persistence
schema to 2.0. And  SchemaConvertionUtil class sets persistence to 2.0 by default.

> Upgrade the geronimo-openejb-2.0.xsd file for new persistence schema
> --------------------------------------------------------------------
>
>                 Key: GERONIMO-5495
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5495
>             Project: Geronimo
>          Issue Type: New Feature
>      Security Level: public(Regular issues) 
>          Components: OpenEJB
>    Affects Versions: 3.0
>            Reporter: Ivan
>            Assignee: viola.lu
>         Attachments: G-5495.patch
>
>
> It is better for us to use the latest persistence schema version in the geronimo-openejb-2.0.xsd
file, and some conversion codes may be required.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message