geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Forrest Xia (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-5509) Invalid deployment descriptor error: cvc-attribute.4: The value '2.0' does not equal the fixed value '1.0' of attribute 'version'
Date Mon, 09 Aug 2010 04:34:15 GMT
Invalid deployment descriptor error: cvc-attribute.4: The value '2.0' does not equal the fixed
value '1.0' of attribute 'version'
---------------------------------------------------------------------------------------------------------------------------------

                 Key: GERONIMO-5509
                 URL: https://issues.apache.org/jira/browse/GERONIMO-5509
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
          Components: deployment
    Affects Versions: 3.0
         Environment: ubuntu 8.04 x86-32
sun java 1.6.0_20
            Reporter: Forrest Xia
         Attachments: dayTrader-derby-plan.xml, daytrader-webprofile-ear-3.0-SNAPSHOT.ear

Steps:
1. start geronimo 3.0 snapshot web profile build
2. deploy the attached daytrader application with the attached deployment plan in the admin
console
3. then an deployment exception throws out like this:

2010-08-09 12:24:03,465 ERROR [DeploymentPortlet] Deployment Failed
Error parsing geronimo-openejb.xml with xmlbeans.  For debug purposes, XML content written
to: /home/forrestxm/temp/geronimo-tomcat7-javaee6-web-3.0-SNAPSHOT/var/temp/openejb-jar-5019648766953734149.xml
org.apache.geronimo.common.DeploymentException: Error parsing geronimo-openejb.xml with xmlbeans.
 For debug purposes, XML content written to: /home/forrestxm/temp/geronimo-tomcat7-javaee6-web-3.0-SNAPSHOT/var/temp/openejb-jar-5019648766953734149.xml
	at org.apache.geronimo.openejb.deployment.XmlUtil.convertToXmlbeans(XmlUtil.java:107)
	at org.apache.geronimo.openejb.deployment.EjbModuleBuilder.createModule(EjbModuleBuilder.java:372)
	at org.apache.geronimo.openejb.deployment.EjbModuleBuilder.createModule(EjbModuleBuilder.java:258)
	at org.apache.geronimo.j2ee.deployment.EARConfigBuilder.addModules(EARConfigBuilder.java:864)
	at org.apache.geronimo.j2ee.deployment.EARConfigBuilder.getEarPlan(EARConfigBuilder.java:457)
	at org.apache.geronimo.j2ee.deployment.EARConfigBuilder.getDeploymentPlan(EARConfigBuilder.java:319)
	at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:231)
	at org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:138)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.apache.geronimo.gbean.runtime.ReflectionMethodInvoker.invoke(ReflectionMethodInvoker.java:34)
	at org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(GBeanOperation.java:131)
	at org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(GBeanInstance.java:872)
	at org.apache.geronimo.kernel.basic.BasicKernel.invoke(BasicKernel.java:245)
	at org.apache.geronimo.deployment.plugin.local.AbstractDeployCommand.doDeploy(AbstractDeployCommand.java:116)
	at org.apache.geronimo.deployment.plugin.local.DistributeCommand.run(DistributeCommand.java:61)
	at java.lang.Thread.run(Thread.java:619)
Caused by: org.apache.xmlbeans.XmlException: Invalid deployment descriptor: errors:

error: cvc-attribute.4: The value '2.0' does not equal the fixed value '1.0' of attribute
'version'

Descriptor:
<xml-fragment xmlns:app="http://geronimo.apache.org/xml/ns/j2ee/application-2.0" xmlns:pkgen="http://openejb.apache.org/xml/ns/pkgen-2.1"
xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.2" xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.2"
xmlns:o="http://openejb.apache.org/xml/ns/openejb-jar-2.2" xmlns:ns6="http://geronimo.apache.org/xml/ns/openejb-clustering-wadi-1.2"
xmlns:ns7="http://geronimo.apache.org/xml/ns/j2ee/ejb/openejb-2.0" xmlns:ns8="http://geronimo.apache.org/xml/ns/security-2.0"
xmlns:ns9="http://java.sun.com/xml/ns/persistence">
  <ns9:persistence version="2.0">
    <ns9:persistence-unit name="daytrader">
      <ns9:properties>
        <ns9:property name="openjpa.jdbc.DBDictionary" value="derby"/>
      </ns9:properties>
    </ns9:persistence-unit>
  </ns9:persistence>
</xml-fragment>

	at org.apache.geronimo.deployment.xmlbeans.XmlBeansUtil.validateDD(XmlBeansUtil.java:188)
	at org.apache.geronimo.schema.SchemaConversionUtils.fixGeronimoSchema(SchemaConversionUtils.java:114)
	at org.apache.geronimo.openejb.deployment.XmlUtil.convertToXmlbeans(XmlUtil.java:93)
	... 18 more


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message