geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: [BUILD] branches/2.2: Failed for Revision: 966762
Date Thu, 22 Jul 2010 23:14:09 GMT

On Jul 22, 2010, at 2:41 PM, gawor@apache.org wrote:

> 
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Geronimo TestSuite :: Commands Testsuite :: Deployer
> [INFO]    task-segment: [install]
> [INFO] ------------------------------------------------------------------------
> [INFO] [genesis:validate-configuration {execution: default}]
> [INFO] [enforcer:enforce {execution: default}]
> [INFO] [remote-resources:process {execution: default}]
> [INFO] [resources:resources]
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
> [INFO] skip non existing resourceDirectory /home/geronimo/geronimo/2.2/testsuite/commands-testsuite/deploy/src/main/resources
> [INFO] skip non existing resourceDirectory /home/geronimo/geronimo/2.2/testsuite/commands-testsuite/deploy/src/main/filtered-resources
> [INFO] Copying 3 resources
> [INFO] [compiler:compile]
> [INFO] No sources to compile
> [INFO] [resources:testResources]
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
> [INFO] Copying 1 resource
> [INFO] skip non existing resourceDirectory /home/geronimo/geronimo/2.2/testsuite/commands-testsuite/deploy/src/test/filtered-resources
> [INFO] Copying 3 resources
> [INFO] [compiler:testCompile]
> [INFO] Nothing to compile - all classes are up to date
> [INFO] [surefire:test]
> [INFO] Tests are skipped.
> [INFO] [jar:jar]
> [INFO] Building jar: /home/geronimo/geronimo/2.2/testsuite/commands-testsuite/deploy/target/deploy-2.2.2-SNAPSHOT.jar
> [INFO] [geronimo:start-server {execution: start}]
> [INFO] Using assembly configuration: tomcat
> [INFO] Using assembly artifact: org.apache.geronimo.assemblies:geronimo-tomcat6-javaee5:zip:bin:2.2.2-SNAPSHOT:provided
> [INFO] Using geronimoHome: /home/geronimo/geronimo/2.2/testsuite/commands-testsuite/deploy/target/geronimo-tomcat6-javaee5-2.2.2-SNAPSHOT
> [INFO] Installing assembly...
> [INFO] Expanding: /home/geronimo/.m2/repository/org/apache/geronimo/assemblies/geronimo-tomcat6-javaee5/2.2.2-SNAPSHOT/geronimo-tomcat6-javaee5-2.2.2-SNAPSHOT-bin.zip
into /home/geronimo/geronimo/2.2/testsuite/commands-testsuite/deploy/target
> [INFO] Starting Geronimo server...
> [INFO] Selected option set: default
> [INFO] Redirecting output to: /home/geronimo/geronimo/2.2/testsuite/commands-testsuite/deploy/target/geronimo-logs/org.apache.geronimo.mavenplugins.geronimo.server.StartServerMojo.log
> [INFO] Waiting for Geronimo server...
> [INFO] Geronimo server started in 0:01:00.777
> [INFO] [:invoke {execution: default}]
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR

Jarek,
I've tried to recreate this error on several systems (including the same server the automated
builds are running on), but haven't been able to recreate. For me, testsuite runs without
any problems. How exactly are the testsuite tests being invoked? I'm just running 'mvn clean
install -Pit'

--kevan 
Mime
View raw message