geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Forrest Xia (JIRA)" <j...@apache.org>
Subject [jira] Closed: (GERONIMO-5403) G 3.0-M1 car-maven-plugin generated plugin dependecies do not have version, that causes plugin installation are panic
Date Thu, 15 Jul 2010 05:19:49 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-5403?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Forrest Xia closed GERONIMO-5403.
---------------------------------

    Fix Version/s: 3.0
       Resolution: Invalid

The plugin project I compiled missed a configuration property of car-maven-plugin:

<useMavenDependencies>
                        <value>true</value>
                        <includeVersion>true</includeVersion>
                        <useTransitiveDependencies>true</useTransitiveDependencies>
                    </useMavenDependencies>

So this jira is not valid for 3.0-M1.

> G 3.0-M1 car-maven-plugin generated plugin dependecies do not have version, that causes
plugin installation are panic
> ---------------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-5403
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5403
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: car-maven-plugin
>    Affects Versions: 3.0-M1
>            Reporter: Forrest Xia
>            Priority: Critical
>             Fix For: 3.0
>
>
> G 3.0-M1 car-maven-plugin generates geronimo-plugin.xml and geronimo-plugins.xml, in
which there are no version info for plugin's dependencies. This may cause problem.
> Saying geronimo plugin A depends on artifact B. The B has two different versions in the
local repository, saying B-v1 and B-v2.
> now issue command 
> $ bin/deploy install-plugin A-v2
> to install plugin from local, The A-v2 should depends on B-v2. But when installation
happens, the B-v1 is pulled from the local repository, that leads the installation failed.
> I checked G 2.2 and see the versions there in the dependencies, but why not for G 3.0-M1?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message