geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Zhang (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMODEVTOOLS-657) When importing the aries blog and trader samples, the content of manifest file changed.
Date Fri, 09 Jul 2010 05:33:49 GMT
When importing the aries blog and trader samples, the content of manifest file changed.
---------------------------------------------------------------------------------------

                 Key: GERONIMODEVTOOLS-657
                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-657
             Project: Geronimo-Devtools
          Issue Type: Bug
          Components: eclipse-plugin
    Affects Versions: 3.0
         Environment: OS: Windows XP
JDK: 1.6_20
Eclipse: 3.6
            Reporter: Chris Zhang
            Assignee: Delos Dai


When I import the aries blog sample and the aries trader sample into eclipse, the content
of MANIFEST.MF file of their web bundle change. But the MANIFEST.MF file of other bundles
don't change. 

Take the blog sample for instance, the content of original MANIFEST.MF is : 

Manifest-Version: 1.0
Implementation-Title: Apache Aries
Implementation-Version: 0.1-incubating
Built-By: admin
Tool: Bnd-0.0.357
Bundle-Name: Apache Aries blog sample web component
Created-By: Apache Maven Bundle Plugin
Web-ContextPath: /blog
Bundle-Vendor: The Apache Software Foundation
Build-Jdk: 1.6.0_20
Bundle-Version: 0.1.0.incubating
Bnd-LastModified: 1277349176296
Bundle-ManifestVersion: 2
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
Bundle-Description: Aries top-level parent pom
Bundle-DocURL: http://www.apache.org
Bundle-SymbolicName: org.apache.aries.samples.blog.web
Import-Package: javax.naming,javax.servlet;version="2.5",javax.servlet
 .http;version="2.5",org.apache.aries.samples.blog.api;version="[0.1,1
 )"


And in eclipse, its content is: 

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: org.apache.aries.samples.blog.web
Bundle-SymbolicName: org.apache.aries.samples.blog.web
Bundle-Version: 1.0.0.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Import-Package: javax.servlet;version="2.5",
 javax.el;version="2.0";resolution:=optional,
 javax.servlet.jsp.el;version="2.0",
 javax.servlet.jsp.tagext;version="2.0",
 javax.servlet.jsp;version="2.0",
 javax.servlet.http;version="2.5"
Web-ContextPath: /blog

Please review it. Thanks.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message