Actuall, now  every time reload the page the navagation tree node will open according to the url.

I think the user may want to check a portlet and those portlets in the same group.

So if we have made a good category then the user will feel it easy to find the related portlets.

On Fri, Jun 11, 2010 at 2:37 PM, Shawn Jiang <genspring@gmail.com> wrote:
To revert the iframe.  Each click will result in a whole dojo tree reload.   The most important thing is that the user context will lost. 

In addition, the problems described in this JIRA is easy to fix.   Including the timeout bug.   I'll find a time to get them done.

Please hold on this patch.  

On Fri, Jun 11, 2010 at 2:08 PM, Rex Wang (JIRA) <jira@apache.org> wrote:

   [ https://issues.apache.org/jira/browse/GERONIMO-5325?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12877725#action_12877725 ]

Rex Wang commented on GERONIMO-5325:
------------------------------------

I think it's pretty hard to replace the iframe with div, and also make our console code more complex, and more bugs will be involved. My intent is to make our console's structure more clear and easy to maintain. It is just an "admin" console with the specified user and not a widely-used web application by the people all-over the world(like GMail), so I think it make sense to do such changes..

> iframe causes some portlets display incorrectly
> -----------------------------------------------
>
>                 Key: GERONIMO-5325
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5325
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues)
>    Affects Versions: 2.2
>            Reporter: Rex Wang
>            Assignee: Ben Liang
>             Fix For: 2.2.1
>
>         Attachments: 5325-Ben_2_new.patch, 5325_Ben.patch, screenshot-1-assembly-portlet.jpg, screenshot-debug-views.jpg, screenshot-huge-blank.jpg
>
>
> #1. The assemble server page is not formatting properly in 2.2.1-SNAPSHOT. Go to assemble server page, click "expert user" and try to scroll down. Unless I make the font type very small, I can't see the system plugins and can't scroll down to them.
> #2, This also cause the debugviews portlet displays incorrectly.
> #3, Go to repository portlet first, and then go to JMS Resources portlet. The scroll bar is pretty long and when you scroll down, you can see  there is a huge blank at the bottom of the page.
> See the attachment.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.




--
Shawn



--
Best Regards
Ben Liang