geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Jiang <genspr...@gmail.com>
Subject Re: [DISCUSSION] change 2.2 branch build JDK from 6 to 5
Date Fri, 18 Jun 2010 01:59:27 GMT
On Fri, Jun 18, 2010 at 12:26 AM, Kevan Miller <kevan.miller@gmail.com>wrote:

>
> On Jun 17, 2010, at 11:33 AM, Rick McGuire wrote:
>
> > On 6/17/2010 11:20 AM, Donald Woods wrote:
> >> I'd be fine with requiring Java SE 6 for 2.2.1 and follow-on releases.
> >>
> >
> > Is that even allowed by the Java EE 5 certification rules?
>
> Yes, but I don't think it really matters. I don't think we have any real
> motivation to move to Java 6 -- there aren't Java 6 features that we're
> planning on taking advantage of...

It's simply someone "built" on Java 6 and found that they had problems
> subsequently "running" on Java 5.
>

Besides someone "built" on Java 6,   there might be other problems when
using Java 6 as runtime.



>
> IMO, we should be building on Java 5 (maintaining support for Java 5), if
> users want to run on Java 6, that's fine...
>

Sure we should maintain support for Java 5.   But for Java 6,  since we
didn't pass the java EE 5 certification with Java 6 as runtime.   It's
better to document that.


>
> --kevan




-- 
Shawn

Mime
View raw message