geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarek Gawor <jga...@gmail.com>
Subject Re: [Question] Why SAAJ RI in trunk?
Date Tue, 01 Jun 2010 14:10:59 GMT
Axis2 SAAJ implementation was not (and still might not be) a
standalone implementation. It required at least the axis2-kernel
module and axis2-kernel required a bunch of other dependencies. The
RI, however, has no other external dependencies.

With OSGi kernel and different bundling options we might be able to
just use Axis2 SAAJ implementation but it's been a while since I've
looked at this.

Jarek

On Tue, Jun 1, 2010 at 9:23 AM, Jack Cai <greensight@gmail.com> wrote:
> We depend on SAAJ RI instead of axis2-saaj. I think axis2-saaj implements
> SAAJ 1.3, which are used in Geronimo 2.1 (Java EE 5). And I thought Java EE
> 6 still requires SAAJ 1.3. Can someone shed some light here?
>
> -Jack
>

Mime
View raw message