geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan <xhh...@gmail.com>
Subject Re: [Geronimo-trunk] Deployment Exception
Date Tue, 08 Jun 2010 12:39:39 GMT
Hi,
    in-place deployment support for trunk is still ongoing :-(

2010/6/8 rahul.soa <rahul.soa@googlemail.com>

> Hello Devs,
>
> I am trying to deploy my webservice client on Geronimo/jetty on freshly
> built "trunk" on linux machine. However, I was able to deploy it on
> Geronimo-2.2. I encounter the following error while deploying:
>
>
> [rahul@localhost bin]$ ./deploy --user system --password manager deploy
> --inPlace /home/rahul/new_workspace1/GerominoWebClient/
> Using GERONIMO_HOME:
> /home/rahul/server/assemblies/geronimo-jetty8-javaee6/target/assembly
> Using GERONIMO_TMPDIR: var/temp
> Using JRE_HOME:        /usr/SDK/jdk/jre
> 2010-06-08 10:24:51,204 ERROR [DeployTool] Error:
> org.apache.geronimo.common.DeploymentException: Unable to deploy
> GerominoWebClient: Unable to create configuration for deployment:
> dependencies: null
>     Unable to cache bundle:
> reference:file:/home/rahul/server/assemblies/geronimo-jetty8-javaee6/target/assembly/var/temp/geronimo-fileutils1096712856251867518.tmpfile
>     error in opening zip file
>
>     at
> org.apache.geronimo.deployment.cli.CommandDeploy.runCommand(CommandDeploy.java:43)
>     at
> org.apache.geronimo.deployment.cli.CommandDistribute.executeOnline(CommandDistribute.java:148)
>     at
> org.apache.geronimo.deployment.cli.CommandDistribute.execute(CommandDistribute.java:124)
>     at
> org.apache.geronimo.deployment.cli.DeployTool.execute(DeployTool.java:173)
>     at
> org.apache.geronimo.system.main.MainBridge.execute(MainBridge.java:64)
>     at org.apache.geronimo.main.Bootstrapper.execute(Bootstrapper.java:65)
>     at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:65)
>     at
> org.apache.geronimo.cli.deployer.DeployerCLI.main(DeployerCLI.java:31)
> [rahul@localhost bin]$
>
>
>
> In the geronimo.log, I see the following logs:
>
> 2010-06-08 10:24:51,091 INFO  [DeploymentContext] The Strict Manifest
> Classpath processing mode is in effect.
> This option can be altered by specifying
> -DXorg.apache.geronimo.deployment.LenientMFCP=true|false
> Specify ="true" for more lenient processing such as ignoring missing jars
> and references that are not spec compliant.
> 2010-06-08 10:25:09,051 INFO  [RedirectByHashFilter] no redirect for:
> http://localhost:8097/console/portal/0/Welcome
> 2010-06-08 10:25:10,615 INFO  [RedirectByHashFilter] Redirecting
> to:/portal/1-3/Server/Server Logs?noxssShowTree=true according to
> hash:4136777600621980337
> 2010-06-08 10:25:11,772 INFO  [RedirectByHashFilter] Hash value for
> page:/portal/1-3/Server/Server Logs is:4136777600621980337
> 2010-06-08 10:25:11,772 INFO  [RedirectByHashFilter] no redirect for:
> http://localhost:8097/console/portal/1-3/Server/Server%20Logs
> 2010-06-08 10:25:11,776 INFO  [SupportedModesServiceImpl] Portlet mode
> 'edit' not found for portletId: 'console-base.LogManager!965326648|0'
> 2010-06-08 10:25:11,958 INFO  [SupportedModesServiceImpl] Portlet mode
> 'edit' not found for portletId: 'console-base.LogViewer!965326648|1'
> 2010-06-08 10:25:12,351 INFO  [SupportedModesServiceImpl] Portlet mode
> 'edit' not found for portletId:
> 'console-base.WebAccessLogViewer!965326648|2'
>
>
> Below is my deployment plan:
>
> geronimo-web.xml
> -----------------------
>
>
> <?xml version="1.0" encoding="UTF-8"?>
> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1"
> xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1"
> xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.1">
>   <environment>
>     <moduleId>
>       <groupId>JEE5</groupId>
>       <artifactId>GeronimoServletClient</artifactId>
>       <version>1.1</version>
>       <type>war</type>
>     </moduleId>
>   </environment>
>
>  <context-root>/GeronimoWebClient</context-root>
> <service-ref>
>    <service-ref-name>services/Calculator</service-ref-name>
>  <port>
>       <port-name>CalculatorPort</port-name>
>       <protocol>http</protocol>
>       <host>localhost</host>
>       <port>8080</port>
>       <uri>/GerominoWeb/calculator</uri>
>       <property name="wss4j.out.action">UsernameToken Timestamp</property>
>       <property name="wss4j.out.passwordType">PasswordText</property>
>       <property name="wss4j.out.user">system</property>
>       <property name="wss4j.out.password">manager</property>
>     </port>
>  </service-ref>
>
> </web-app>
>
>
>
> Can you please guide me why/what happens? How to resolve this issue? I use
> the same deployment plan on Geronimo-2-2 and it worked well but not in
> trunk.
>
> Also on the web console, under system modules, I don't see any cxf module.
> Is it normal?
>
> Many Thanks for your help.
>
> Rahul
>
>
>


-- 
Ivan

Mime
View raw message