geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <dwo...@apache.org>
Subject Re: [DISCUSSION] change 2.2 branch build JDK from 6 to 5
Date Thu, 17 Jun 2010 20:13:23 GMT
OK, just found GERONIMO-5369 and it turns out not to be an issue, so
lets stay with SE 5 for 2.2.


-Donald


On 6/17/10 12:26 PM, Kevan Miller wrote:
> 
> On Jun 17, 2010, at 11:33 AM, Rick McGuire wrote:
> 
>> On 6/17/2010 11:20 AM, Donald Woods wrote:
>>> I'd be fine with requiring Java SE 6 for 2.2.1 and follow-on releases.
>>>   
>>
>> Is that even allowed by the Java EE 5 certification rules?
> 
> Yes, but I don't think it really matters. I don't think we have any real motivation to
move to Java 6 -- there aren't Java 6 features that we're planning on taking advantage of...
It's simply someone "built" on Java 6 and found that they had problems subsequently "running"
on Java 5. 
> 
> IMO, we should be building on Java 5 (maintaining support for Java 5), if users want
to run on Java 6, that's fine...
> 
> --kevan 

Mime
View raw message