geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Gawor (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (GERONIMO-5270) Enforce Java1.6 for Geronimo 3.0 build in maven and perhaps enforce the required maven version as well (2.2.1?).
Date Mon, 14 Jun 2010 18:49:13 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-5270?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jarek Gawor resolved GERONIMO-5270.
-----------------------------------

      Assignee: Jarek Gawor
    Resolution: Fixed

Java 6 and Maven 2.2.1 are now enforced in trunk. Committed in revision 954586.


> Enforce Java1.6 for Geronimo 3.0 build in maven  and perhaps enforce the required maven
version as well (2.2.1?).
> -----------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-5270
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5270
>             Project: Geronimo
>          Issue Type: Improvement
>      Security Level: public(Regular issues) 
>          Components: buildsystem
>    Affects Versions: 3.0
>            Reporter: Joe Bohn
>            Assignee: Jarek Gawor
>             Fix For: 3.0
>
>
> I believe that Geronimo 3.0 must be built using java 1.6 and fails if that is not the
case.  However, it isn't a nice failure.  We should configure maven to check the java version
and fail if it isn't 1.6.   
> We should also consider checking the maven version and enforcing a minimum maven version
- I've heard that 2.2.1 is required.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message