geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Forrest Xia (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-5373) Enable previous released geronimo 2.2 plugins installable on G 2.2.1
Date Thu, 10 Jun 2010 03:23:14 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-5373?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12877299#action_12877299
] 

Forrest Xia commented on GERONIMO-5373:
---------------------------------------

After the modifications, only part of G 2.2 released samples' plugins work on G 2.2.1:

Work:
1. org.apache.geronimo.samples/app-per-port-tomcat/2.2/car 
2. org.apache.geronimo.samples/jsp-examples-tomcat/2.2/car 
3. org.apache.geronimo.samples/ldap-sample-app-tomcat/2.2/car 
4. org.apache.geronimo.samples/servlet-examples-tomcat/2.2/car 
5. org.apache.geronimo.samples/sendmail-tomcat/2.2/car 
6. org.apache.geronimo.samples/jaxws-calculator-tomcat/2.2/car 
7. org.apache.geronimo.samples/dbtester-tomcat/2.2/car 


Not work:
8. org.apache.geronimo.samples/sample-datasource/2.2/car -- GenericConnectionManagerGBean
is rewrited via GBean annotation, it's not compatible with the static GBean declaration one.
9. org.apache.geronimo.samples/bank-tomcat/2.2/car -- Lack of sample-datasource
10. org.apache.geronimo.samples/calculator-tomcat/2.2/car --  Incompatible OpenEJB serialVersionUID
11. org.apache.geronimo.samples/customer-tomcat/2.2/car --  Lack of sample-datasource
12 org.apache.geronimo.samples/jms-mdb-tomcat/2.2/car  --   Incompatible OpenEJB serialVersionUID
13 org.apache.geronimo.samples/myphonebook-tomcat/2.2/car --  Incompatible OpenEJB serialVersionUID
14 org.apache.geronimo.samples/mytime-tomcat/2.2/car -- Incompatible OpenEJB serialVersionUID
15 org.apache.geronimo.samples/inventory-tomcat/2.2/car --  Incompatible OpenEJB serialVersionUID
16 org.apache.geronimo.samples/timereport-tomcat/2.2/car --  Incompatible OpenEJB serialVersionUID

But with the new deployers in G 2.2.1, all of the samples' plugins works. So the backward
compatibility is kind of hard to achieve between G releases :(

> Enable previous released geronimo 2.2 plugins installable on G 2.2.1
> --------------------------------------------------------------------
>
>                 Key: GERONIMO-5373
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5373
>             Project: Geronimo
>          Issue Type: Improvement
>      Security Level: public(Regular issues) 
>    Affects Versions: 2.2.1
>            Reporter: Forrest Xia
>            Assignee: Forrest Xia
>            Priority: Minor
>
> Seems <artifact-alias key="${groupId}/${artifactId}//car">${groupId}/${artifactId}/${version}/car</artifact-alias>
config cannot make 2.2 plugins installable on G 2.2.1, need to add another line for this.
> <artifact-alias key="${groupId}/${artifactId}/2.2/car">${groupId}/${artifactId}/${version}/car</artifact-alias>

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message