geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Struberg (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-5396) java.util.logging resources doesn't get picked up
Date Wed, 23 Jun 2010 12:18:04 GMT
java.util.logging resources doesn't get picked up
-------------------------------------------------

                 Key: GERONIMO-5396
                 URL: https://issues.apache.org/jira/browse/GERONIMO-5396
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
          Components: Logging
    Affects Versions: 3.0-M1
            Reporter: Mark Struberg


In OpenWebBeans we use the i18n resource capabilities of java.util.logging.Logger

In the code:
{noformat} 
Logger logger = Logger#getLogger(String name, String resourceBundleName);
logger.info("INFO_0004", param),
{noformat} 
In the Message resources:
{noformat} 
INFO_0004=Adding OpenWebBeansPlugin \: [{0}]
{noformat} 
Where {0} gets filled with the value of 'param'.

In geronimo I only see: "[BeansDeployer] INFO_0004"

, so the jul to slf4j bridge doesn't handle the message bundle.

Also if I add the String myself and call
{noformat} 
logger.info("message with param {0}", "rabbit");
{noformat} 
I still get no parameter filling, so the resulting text in the logfile is "message with param
{0}"


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message