geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarek Gawor <jga...@gmail.com>
Subject Re: preventing build rot
Date Sat, 08 May 2010 04:15:22 GMT
Will I be able to build M1 with Maven 2.2.1 after your Maven 3
changes? If yes, then I'm -0 but if not, then I'm -1 because it's
kinda late to make any type of build changes and these changes always
generate more problems.

Jarek

On Fri, May 7, 2010 at 8:36 PM, David Jencks <david_jencks@yahoo.com> wrote:
> I think it's about time to upgrade genesis to the apache 7 pom and see what we can leave
out,
>
> and also to upgrade to maven 3.  I have the build running on maven 3 locally and plan
to commit the required changes shortly.  After trying it out I really don't want to go back
:-)
>
> Along with the generally better user experience with maven 3 we'll be able to start using
import scope reliably.
>
> I don't see a problem with the changes to make maven 3 work for the 3.0 M! -- I don't
want to require maven 3 for it -- but upgrading genesis is certainly a post-m1 activity.
>
> thoughts?
>
> thanks
> david jencks
>
>

Mime
View raw message