geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Forrest Xia <forres...@gmail.com>
Subject jaxb-xjc and jaxb-impl should have the same version number in G trunk and 3.0 M1 branch
Date Wed, 26 May 2010 03:40:00 GMT
Hi,

Recently, when I work on a JIRA(
https://issues.apache.org/jira/browse/GERONIMO-5314) for G 2.2 branch, I see
a cxf wsdl2java command failure caused by mismatch version of jaxb-xjc and
jaxb-impl.

After check the trunk and 3.0 M1 branch, I see the difference too. jaxb-xjc
is still 2.1.7, while jaxb-impl is a bundlized version which uses jaxb-impl
2.2. I think we need to make the aligned in the same version level to avoid
potential issues. Any thoughts?

If that is OK, I will create a patch for trunk and M1.

Forrest

Mime
View raw message