geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: [VOTE] Release Geronimo axis2 and axiom-api bundles (Second Try)
Date Wed, 19 May 2010 13:41:38 GMT
Have we had a conversation with the axis community regarding the split-package issue?

Minor point: I note the license/notice files in the jar have different line endings (mix of
unix and windows line endings). Would prefer that we avoid this, but end of the day it's a
minor issue...

It looks like there are some Axis2 fixes that we should be picking up from the Axis community.
I think they should be included in our bundle release. Here's my -1. 

--kevan

On May 17, 2010, at 11:51 PM, Ivan wrote:

> Please vote for the geronimo axis2 and axiom-api bundle release, add Notice and License
files for axis2 and axiom-api
> 
> axis2-1.5 : For there is split-package issue in the axis2 bundles which Geronimo requires.
> axiom-api 1.2.8 : The official bundle does not import javax.xml.stream.util package,
althought Geronimo trunk works under JRE 1.6, while the package is not exported by the framework
bundle, as we use our own stax bundle.
> 
> Staging repo is here:
> 
> https://repository.apache.org/content/repositories/orgapachegeronimo-002/
> 
> tag is here:
> 
> https://svn.apache.org/repos/asf/geronimo/bundles/tags/axiom-api-1.2.8_1/
> https://svn.apache.org/repos/asf/geronimo/bundles/tags/axis2-1.5_1/ 
> 
> Vote open 72 hours
> 
> [ ] +1 release this
> [ ] 0 don't care
> [ ] -1 don't release this (please explain)
> 
> 
> -- 
> Ivan


Mime
View raw message