geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarek Gawor <jga...@gmail.com>
Subject Issues with saaj & annotation specs
Date Fri, 09 Apr 2010 04:12:38 GMT
Rick,

I've noticed two issues with saaj & annotation specs.

1) The etc/config.properties exposes javax.xml.soap with version 1.3
through the system bundle. That's the same package & version as
geronimo-saaj_1.3_spec which means the geronimo saaj spec is not
really being used at runtime. So I think we should remove that package
from exports from the system bundle.

2) The etc/config.properties also exposes
javax.annotation*;version=1.0 and Geronimo provides
geronimo_annotation_1.1_spec. That's ok but I'm still seeing some
bundles getting wired to the annotation packages from the system
bundle which causes problems. So can those packages be also removed
from the system bundle?

Jarek

Mime
View raw message