geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Bohn (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-5270) Enforce Java1.6 for Geronimo 3.0 build in maven and perhaps enforce the required maven version as well (2.2.1?).
Date Fri, 23 Apr 2010 21:11:51 GMT
Enforce Java1.6 for Geronimo 3.0 build in maven  and perhaps enforce the required maven version
as well (2.2.1?).
-----------------------------------------------------------------------------------------------------------------

                 Key: GERONIMO-5270
                 URL: https://issues.apache.org/jira/browse/GERONIMO-5270
             Project: Geronimo
          Issue Type: Improvement
      Security Level: public (Regular issues)
          Components: buildsystem
    Affects Versions: 3.0
            Reporter: Joe Bohn
             Fix For: 3.0


I believe that Geronimo 3.0 must be built using java 1.6 and fails if that is not the case.
 However, it isn't a nice failure.  We should configure maven to check the java version and
fail if it isn't 1.6.   

We should also consider checking the maven version and enforcing a minimum maven version -
I've heard that 2.2.1 is required.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message