geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick McGuire <rick...@gmail.com>
Subject Re: Geronimo specs and OSGi package export versions
Date Fri, 09 Apr 2010 14:15:32 GMT
On 4/9/2010 9:48 AM, Kevan Miller wrote:
> Thanks for the update, Rick.
>
> Have you made the OpenJPA community aware of this issue?
>    

No, not yet.  I was looking for a little more feedback here to make sure 
we had some consensus on what we'd like to ask for before I did that.

And I've found another issue with the servlet spec.  I've been trying to 
rebuild Geronimo using a servlet spec that exports the 2.6 level.  I 
first ran into a problem with Tomcat, but that was easily resolved by 
rebuilding the external tomcat component we use.  Jetty, however, is a 
problem.  We're currently using the 8.0.0.M0 version of Jetty, which has 
it's own version of the spec classes.  We pick this up and exclude their 
version of the api definitions, but their version is also using 3.0 for 
the servlet packages, which means we can't use these bundles directly.  
I suspect the same trick I used with JPA will work here too.

Rick

> --kevan
>
>
>    


Mime
View raw message