geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rex Wang <rwo...@gmail.com>
Subject Re: time to use maven 2.2.1 for G2.1.5 daily build
Date Mon, 15 Mar 2010 01:24:44 GMT
hi, Donald, in
http://maven.apache.org/developers/release/apache-release.html
A prerequisite says:
"you must use Maven 2.2.1, as Maven 2.0.x cannot deploy over SCP to the ASF,
and Maven 2.1.0 and 2.2.0 produce incorrect GPG signatures and checksums
respectively."

I think we have to use 2.2.1..

2010/3/12 Donald Woods <dwoods@apache.org>

> +1 to using Genesis 2.0 as this lets us use Nexus to deploy artifacts
> (this was discussed in another thread awhile back.)
>
> -1 to requiring Maven 2.2.1, as Genesis 2.0 only requires 2.0.10 or later -
>
>
> https://svn.apache.org/repos/asf/geronimo/genesis/tags/genesis-2.0/genesis-default-flava/pom.xml
> -
>
> ...
>            <plugin>
>                <groupId>org.apache.maven.plugins</groupId>
>                <artifactId>maven-enforcer-plugin</artifactId>
>                <executions>
>                    <execution>
>                        <phase>validate</phase>
>                        <goals>
>                            <goal>enforce</goal>
>                        </goals>
>                        <configuration>
>                            <rules>
>                                <requireMavenVersion>
>                                    <version>[2.0.10,)</version>
>                                </requireMavenVersion>
>                            </rules>
>                        </configuration>
>                    </execution>
>                </executions>
>            </plugin>
> ...
>
>
> -Donald
>
>
> On 3/11/10 10:42 AM, Forrest Xia wrote:
> > To use apache-release profile and maven release plugin to do release, I
> > guess :-)
> >
> > Forrest
> >
> > On Thu, Mar 11, 2010 at 9:46 PM, Kevan Miller <kevan.miller@gmail.com
> > <mailto:kevan.miller@gmail.com>> wrote:
> >
> >
> >     On Mar 11, 2010, at 3:54 AM, Rex Wang wrote:
> >
> >     > Hi Jarek,
> >     > Could you help update the scripts?
> >
> >     Read more of my mail... ;-) So, I assume *why* is because of the
> >     move to Genesis 2.0. So, brings up a new question... ;-) Why update
> >     G 2.1 to use Genesis 2.0?
> >
> >     --kevan
> >
> >
>



-- 
Lei Wang (Rex)
rwonly AT apache.org

Mime
View raw message