geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Delos <dait...@gmail.com>
Subject Re: Eclipse plugin-versions
Date Wed, 03 Mar 2010 03:11:07 GMT
I tried latest GEP 2.2 from
http://apache.org/dist/geronimo/eclipse/updateswith eclipse 3.5.2,
everything goes well. I guess you installed an old
version of eclipse.


在 2010年3月2日 下午7:43,office@weberhofer.at <office@weberhofer.at>写道:

> Dear Delos,
>
> I have the impression, that GEP is very sensitive regarding Eclipse and WTP
> version numbers. I have always had the problem that after upgrading I was no
> longer able to install the GEP plugin. Currently the plugin from
> http://apache.org/dist/geronimo/eclipse/updates/ can not be installed on
> Eclipse 3.5.2 because it says "Missing requirement: Geronimo Core Feature
> 2.1.1 (org.apache.geronimo.feature.feature.group 2.1.1) requires
> 'org.eclipse.jst.feature.group [2.0.0,3.0.0)' but it could not be found"
>
> I fully agree with you, that the best thing would be to support multiple
> Eclipse versions with one GEP plugin, currently I know, that the plugin is
> running on Eclipse 3.5 and 3.5-SR1 but not on it's SR2 release. I haven't
> tried with 3.4 versions.
>
> The plugin is somewhere in the middle of Geronimo and Eclipse, so if
> different Eclipse versions are supported, it could be useful to publish
> minor releases (like 2.2.0.1) which fixes some issues like supporting newer
> Eclipse versions, even when the next Geronimo version is still some time
> ahead.
>
> Best regards,
> Johannes
>
>
> Am 02.03.2010 04:05, schrieb Delos:
> > hi Johannes,
> >
> > Thanks for your attention! But I don't think it's a good idea to keep a
> > separated version for GEP. Here are my thoughts. Hopefully, other people
> > may also share their point of view about this to improve GEP.
> >
> > GEP is a sub-project of Geronimo. So it's reasonable for GEP version to
> > keep consistent with Geronimo server.
> >
> > Eclipse is used as a dependency in GEP build process.Eclipse itself has
> > a new release every year. We certainly need to support the latest
> > eclipse. But that doesn't mean we drop the support for old eclipse.
> > Normally, GEP is back compatible, unless any used eclipse API changed.
> > If the change happens, user may install old GEP accordingly. I think
> > it's also reasonable for a eclipse plugin.
> >
>
> --
>
>
> |---------------------------------
> |  weberhofer GmbH             | Johannes Weberhofer
> |  information technologies    |
> |  Austria, 1080 Wien, Blindengasse 52/3
> |------------------------------------------------------------->>
>



-- 
Best Regards,

Delos

Mime
View raw message