geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarek Gawor <jga...@gmail.com>
Subject Re: GERONIMO-5174
Date Mon, 08 Mar 2010 19:25:53 GMT
On Mon, Mar 8, 2010 at 12:41 PM, Rick McGuire <rickmcg@gmail.com> wrote:
>
> I saw some similar problems some time ago, and generally the problem seems
> to occur when when bundles import packages without an explicit version
> identified.  This allows the wiring to be made to the system bundle rather
> than the "correct" 2.2 one.  If I remember correctly, this problem was
> solved by making sure that there's only one version of the package to wire
> to.  I might also have fixed up some of the imports to explicitly specify
> the version required.

I thought that imports without upper version range are automatically
wired to the bundle that exports the given package with highest
version.

Jarek

Mime
View raw message