geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarek Gawor <jga...@gmail.com>
Subject GERONIMO-5174
Date Mon, 08 Mar 2010 17:26:18 GMT
Hi,

I was working on GERONIMO-5174 and ran into a problem that I'm not
sure why it is happening. I'm hoping somebody might have an idea on
what's going on.

I applied the patch in GERONIMO-5174 and tried building Geronimo. With
Felix the build "hang" (looking for consistent class space) when
building cxf or axis2 ejb plugin. On Equinox the build failed with
"Package uses conflict" when building the openejb-deployer plugin.
>From what I can tell some bundles (openejb core & client) wire to
javax.xml.ws packages from the system bundle and some
(geronimo-j2ee-builder, geronimo-openejb-builder) wire to geronimo
jax-ws 2.2 spec bundle. However, I'm not sure why openejb bundles wire
to javax.xml.ws from system bundle in the first place since the
geronimo jax-ws 2.2 spec bundle is installed and resolved before the
openejb bundles are installed and resolved.

The openejb bundles import the javax.xml.ws packages without a version
while the geronimo bundles import with version="2.2".

I modified the DependencyManager to resolve the installed bundles
using PackageAdmin and verified that openejb modules get
installed/resolved after the geronimo jax-ws 2.2 spec bundle is, so
I'm not really sure what's going on. Any ideas?

Jarek

Mime
View raw message