geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shawn Jiang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMO-5134) G 2.1 branch use wrong geronimo-jpa spec version
Date Thu, 11 Feb 2010 03:44:28 GMT

    [ https://issues.apache.org/jira/browse/GERONIMO-5134?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12832374#action_12832374
] 

Shawn Jiang commented on GERONIMO-5134:
---------------------------------------

There is a hard coded jpa_3.0 in following file that was not updated.

\plugins\jaxws\geronimo-jaxws-builder\src\main\java\org\apache\geronimo\jaxws\builder\JAXWSTools.java

Just committed the fix to the g21 branch.

> G 2.1 branch use wrong geronimo-jpa spec version
> ------------------------------------------------
>
>                 Key: GERONIMO-5134
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5134
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: buildsystem
>    Affects Versions: 2.1.5
>            Reporter: Forrest Xia
>            Assignee: Donald Woods
>             Fix For: 2.1.5
>
>         Attachments: GERONIMO-5134.patch
>
>
> In some pom.xml, there is a dependency:
> <dependency>
>                 <groupId>org.apache.geronimo.specs</groupId>
>                 <artifactId>geronimo-jpa_3.0_spec</artifactId>
>                 <version>1.1.1</version>
> </dependency>
> it should be updated to
> <dependency>
>                 <groupId>org.apache.geronimo.specs</groupId>
>                 <artifactId>geronimo-jpa_1.0_spec</artifactId>
>                 <version>1.1.2</version>
> </dependency>

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message