geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: What process to follow to release geronimo samples?
Date Thu, 14 Jan 2010 18:01:43 GMT
Actually, I did get site generation working (or at least working good 
enough) back in genesis 1.4 or 1.5 and I used it for several component 
releases.  I recall a post from Jason when Genesis 2.0 was getting close 
to complete indicating that the site generation worked but there were 
some issues with the Geronimo skin.  I think the work was eventually 
deferred and nobody ever picked it up again.

Joe


David Jencks wrote:
> AFAIK no one has gotten any sites to generate properly using genesis.  I 
> find site generation to be incomprehensible and full of bugs, I gave up 
> trying to build the site for geronimo 2.2.
> 
> There shouldn't be any snapshots in the site generation process, so 
> perhaps there is an unspecified version somewhere??  I'd guess we'd want 
> a geronimo-skin 2.0 since I think it's from genesis.  Maybe it's called 
> something else now????
> 
> Assuming you are working on releasing samples/branches/2.2 I noticed 
> that at least the root pom needs some cleanup...
> 
> - scm location info is wrong
> - you shouldn't need any repo configuration
> - some of the pllugins are already configured correctly in genesis
> 
> thanks
> david jencks
> 
> On Jan 14, 2010, at 7:43 AM, Forrest Xia wrote:
> 
>> I tried mvn site:run on samples, but get an error that 
>> geronimo-skin:1.5-SNAPSHOT cannot be found.
>>
>> I cannot locate where the artifact is specified in the pom hierarchy. 
>> Could anyone tell me about it? thanks a lot!
>>
>> I notice geronimo-skin:1.5 has been released in the public repo.
>>
>> Forrest
> 
> 


Mime
View raw message