geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan <xhh...@gmail.com>
Subject Re: console broken in trunk?
Date Wed, 20 Jan 2010 09:23:01 GMT
I got the failed ClusteredManagerTest unit case, too. Will check what's
wrong.
For automated build, from the recent daily report message, it was always
caused by failing to downloading some servicemix snapshots. Not sure all
those snapshots could be found anywhere, for I always build those artifacts
from source codes on my own machine.

2010/1/20 David Jencks <david_jencks@yahoo.com>

> I think we need to get our automated builds working and set up some kind of
> simple way to see if the test servers start without major errors.
>
> I'm having a test failure
> in   plugins/tomcat/geronimo-tomcat7-clustering-wadi/src/test/java/org/apache/geronimo/tomcat/cluster/ClusteredManagerTest.java
> which I can't understand and after I disable the failing test the server
> builds and the console-jetty-server sort of starts but looking at the
> console gives
>
>
> HTTP ERROR 500
>
> Problem accessing /console/portal/welcome. Reason:
>
>     PageConfig for render path [/welcome] could not be found.
>
>
> Caused by:
>
> javax.servlet.ServletException: PageConfig for render path [/welcome] could not be found.
> 	at org.apache.pluto.driver.PortalDriverServlet.doGet(PortalDriverServlet.java:179)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:575)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
> 	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:532)
> 	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1232)
> 	at org.apache.geronimo.console.filter.RedirectByHashFilter.doFilter(RedirectByHashFilter.java:116)
>
> ...
>
>
> I suspect that this might be caused by the changes I made recently to load the gbean
classes from a specified plugin rather than the app's bundle: the welcome app worked but I
didn't test the console.
>
> In any case I wondered if anyone else has the console working or if they see a similar
error.  I'm happy to work on fixing it but I'd like to check that it isn't caused by something
odd in my environment.
>
>
> thanks
>
> david jencks
>
>
>


-- 
Ivan

Mime
View raw message