geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Delos Dai (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-601) Module config Id not found for undeployment
Date Mon, 25 Jan 2010 07:15:34 GMT

    [ https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-601?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12804423#action_12804423
] 

Delos Dai commented on GERONIMODEVTOOLS-601:
--------------------------------------------

Hi Ted,

I tried your package with lib containing com.ibm.websphere.xs on Linux and Windows. I modified
some texts in java and jsp files, seems the redeployment worked fine. Could you tell me what's
the exact change you did? 

> Module config Id not found for undeployment
> -------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-601
>                 URL: https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-601
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 2.2.0
>         Environment: MacOS
> eclipse, Galileo SR1, Eclipse Java EE IDE for Web Developers,
> Build id: 20090902-1017
> I am running in a Mac with this java:
> >java -version
> java version "1.6.0_17"
> Java(TM) SE Runtime Environment (build 1.6.0_17-b04-248-9M3125)
> Java HotSpot(TM) 64-Bit Server VM (build 14.3-b01-101, mixed mode)
>            Reporter: Ted Kirby
>            Assignee: Delos Dai
>            Priority: Minor
>         Attachments: GetnStarted3AG.zip
>
>
> I have created a dynamic web project and it seems to work fine.  I can
> deploy and use the war file, and it gets republished if I change
> source.  However, on every deploy/republish, I get this error in
> eclipse:
> Module config Id not found for undeployment
> java.lang.NullPointerException
> at org.apache.geronimo.st.core.jaxb.JAXBUtils.unmarshalFilterDeploymentPlan(JAXBUtils.java:126)
> at org.apache.geronimo.st.v21.core.GeronimoV21Utils.getWebDeploymentPlan(GeronimoV21Utils.java:236)
> at org.apache.geronimo.st.v21.core.GeronimoV21Utils.getWebDeploymentPlan(GeronimoV21Utils.java:199)
> at org.apache.geronimo.st.v21.core.GeronimoV21Utils.getWebDeploymentPlan(GeronimoV21Utils.java:179)
> at org.apache.geronimo.st.v21.core.GeronimoV21Utils.getConfigId(GeronimoV21Utils.java:119)
> at org.apache.geronimo.st.v21.core.GeronimoV21VersionHandler.getConfigID(GeronimoV21VersionHandler.java:36)
> at org.apache.geronimo.st.core.commands.UndeployCommand.execute(UndeployCommand.java:53)
> at org.apache.geronimo.st.core.commands.SynchronizedDeploymentOp.run(SynchronizedDeploymentOp.java:84)
> at org.apache.geronimo.st.core.commands.SynchronizedDeploymentOp.execute(SynchronizedDeploymentOp.java:76)
> at org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.unDeploy(GeronimoServerBehaviourDelegate.java:740)
> at org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.doRemoved(GeronimoServerBehaviourDelegate.java:666)
> at org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.invokeCommand(GeronimoServerBehaviourDelegate.java:451)
> at org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.publishModule(GeronimoServerBehaviourDelegate.java:318)
> at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModule(ServerBehaviourDelegate.java:948)
> at org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.publishModules(GeronimoServerBehaviourDelegate.java:273)
> at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:872)
> at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:708)
> at org.eclipse.wst.server.core.internal.Server.publishImpl(Server.java:2690)
> at org.eclipse.wst.server.core.internal.Server$PublishJob.run(Server.java:272)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
> If I export the project as a war file, and deploy it to geronimo, I
> don't get the error, so I suspect it's a GEP problem.
> Here is my geronimo-web.xml file:
> <?xml version="1.0" encoding="UTF-8"?>
> <web:web-app xmlns:app="http://geronimo.apache.org/xml/ns/j2ee/application-2.0"
>        xmlns:client="http://geronimo.apache.org/xml/ns/j2ee/application-client-2.0"
>        xmlns:conn="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2"
>        xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2"
> xmlns:ejb="http://openejb.apache.org/xml/ns/openejb-jar-2.2"
>        xmlns:log="http://geronimo.apache.org/xml/ns/loginconfig-2.0"
>        xmlns:name="http://geronimo.apache.org/xml/ns/naming-1.2"
> xmlns:pers="http://java.sun.com/xml/ns/persistence"
>        xmlns:pkgen="http://openejb.apache.org/xml/ns/pkgen-2.1"
> xmlns:sec="http://geronimo.apache.org/xml/ns/security-2.0"
>        xmlns:web="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
>        <dep:environment>
>                <dep:moduleId>
>                        <dep:groupId>com.ibm.websphere.xs.sample</dep:groupId>
>                        <dep:artifactId>GettnStarted3</dep:artifactId>
>                        <dep:version>1.0</dep:version>
>                        <dep:type>jar</dep:type>
>                </dep:moduleId>
>                <dep:dependencies>
>                        <dep:dependency>
>                                <dep:groupId>com.ibm.websphere.xs</dep:groupId>
>                                <dep:artifactId>ogclient</dep:artifactId>
>                                <dep:version>7.0</dep:version>
>                                <dep:type>jar</dep:type>
>                        </dep:dependency>
>                        <dep:dependency>
>                                <dep:groupId>com.ibm.websphere.xs</dep:groupId>
>                                <dep:artifactId>objectgrid</dep:artifactId>
>                                <dep:version>7.0</dep:version>
>                                <dep:type>jar</dep:type>
>                        </dep:dependency>
>                        <dep:dependency>
>                                <dep:groupId>org.apache.geronimo.configs</dep:groupId>
>                                <dep:artifactId>system-database</dep:artifactId>
>                        </dep:dependency>
>                </dep:dependencies>
>        </dep:environment>
>        <web:context-root>/GetnStarted3AG</web:context-root>
>        <name:resource-ref>
>                <name:ref-name>jdbc/CRUD_DS</name:ref-name>
>                <name:resource-link>SystemDatasource</name:resource-link>
>        </name:resource-ref>
> </web:web-app>
> I will attach my project.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message