geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: welcome app in trunk
Date Mon, 18 Jan 2010 08:38:48 GMT
Hi Ivan,

The patch looks good to me.  I had hoped that since deployment now  
produces a packed jar file we could dispense with ArchiveCarMojo  
entirely and just attach the car file to the project, but Ivan pointed  
out to me on IRC that we still have to install the LICENSE and NOTICE  
files.  It would be nice to use maven-remote-resources-plugin for that  
but I don't have any idea how at the moment and it certainly doesn't  
seem very high priority.

many thanks!  it is great to have this working!

david jencks

On Jan 17, 2010, at 6:53 AM, Ivan wrote:

> Hi, David:
>     Do you have any comment for the proposed patch about the WAR  
> deployment (Geronimo-5009) ?
>     Thanks !
>
> 2010/1/17 David Jencks <david_jencks@yahoo.com>
>
> On Jan 16, 2010, at 12:47 AM, David Jencks wrote:
>
>>
>> On Jan 15, 2010, at 6:25 PM, David Jencks wrote:
>>
>>>
>>> On Jan 15, 2010, at 5:51 PM, Ivan wrote:
>>>
>>>> 2010/1/16 Jarek Gawor <jgawor@gmail.com>
>>>> Hey folks,
>>>>
>>>> I tried building a server with welcome app with Tomcat in trunk and
>>>> ran into a few of problems (at least one of which I thought was
>>>> previously fixed). I'm getting these error when starting a server  
>>>> with
>>>> welcome app:
>>>> 1) GERONIMO-5033 - there is a number of warning from Tomcat about
>>>> missing xsd/dtd files from servlet spec and possible from jsp  
>>>> spec (or
>>>> missing import somewhere)
>>>>   Yes, I wish to add them in a few days ago, but not sure the  
>>>> license issue, so ...
>>>>
>>>> 2) java.lang.ClassNotFoundException:
>>>> org.apache.geronimo.tomcat.listener.DispatchListener - thought this
>>>> was already fixed
>>>>
>>>>   It is a classloader issue, you could just uncomment the  
>>>> createWrapper method in GeronimoStandardContext to avoid it. I  
>>>> guess that Tomcat is fixing in now ?
>>>
>>> Tomcat has basically declined to do anything useful about this.   
>>> Maybe I accidentally commented out the original fix?
>>
>> I did and re-uncommented the g. fix.  My server is in too many  
>> pieces spread out over the floor to see if the welcome app will now  
>> start in it :-(
>
> I put things back together a bit and I can get the tomcat-welcome- 
> server to start.  I see the missing xsd warnings but the welcome app  
> seems to work fine.
>
> david jencks
>
>>
>> david jencks
>>
>>>
>>> thanks
>>> david jencks
>>>>
>>>> 3) java.lang.NullPointerException at
>>>> org.apache.catalina.startup.WebXml.configureContext(WebXml.java: 
>>>> 1152)
>>>> - might be a separate problem or be caused by 1) or 2).
>>>>
>>>>  I did not remember I got this error, could you please check it  
>>>> after solving the issue 2 ?
>>>>
>>>>
>>>> Is anybody else seeing these problems too? i thought the welcome  
>>>> app
>>>> used to work fine.
>>>>
>>>> Jarek
>>>>
>>>>
>>>>
>>>> -- 
>>>> Ivan
>>>
>>
>
>
>
>
> -- 
> Ivan


Mime
View raw message