geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <j...@apache.org>
Subject [jira] Closed: (GERONIMO-4844) There is an error after undeploy the application and deploy the application again when configure WADI clustering,
Date Wed, 27 Jan 2010 02:00:34 GMT

     [ https://issues.apache.org/jira/browse/GERONIMO-4844?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Jencks closed GERONIMO-4844.
----------------------------------

       Resolution: Fixed
    Fix Version/s: 3.0
                   2.2.1

I had to stop using ConfigurationUtil and adjust the expections a little bit to get rmock
to pass.

Nice work!

2.1 rev 903520
2.2 rev 903521
3.0 rev 903525

> There is an error after undeploy the application and  deploy the application again when
configure WADI clustering,
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: GERONIMO-4844
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-4844
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: Clustering
>    Affects Versions: 2.1.4, 2.2
>         Environment: windows:sp2
> jdk1.6
>            Reporter: liangkun
>            Assignee: Shawn Jiang
>             Fix For: 2.1.5, 2.2.1, 3.0
>
>         Attachments: GERONIMO-4844.patch
>
>
> I deploy the application cviewer.war after undeploy it when configure the WADI clustering
,the there is an error:
> org.apache.geronimo.common.DeploymentException: Unable to deploy cviewer-2.1.1.2.war:
Module com.ibm.wasce.samples/cviewer/2.1.1.2/car already exists in the server.  Try to undeploy
it first or use the redeploy command.
> 	at org.apache.geronimo.deployment.cli.CommandDeploy.runCommand(CommandDeploy.java:45)
> 	at org.apache.geronimo.deployment.cli.CommandDistribute.executeOnline(CommandDistribute.java:139)
> 	at org.apache.geronimo.deployment.cli.CommandDistribute.execute(CommandDistribute.java:125)
> 	at org.apache.geronimo.deployment.cli.DeployTool.execute(DeployTool.java:168)
> 	at org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(MainConfigurationBootstrapper.java:45)
> 	at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:65)
> 	at org.apache.geronimo.cli.deployer.DeployerCLI.main(DeployerCLI.java:31)
> However,actually,there are no any module in the server.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message