geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <j...@apache.org>
Subject [jira] Created: (GERONIMO-4974) ee apps or other plugins can't contain gbeans
Date Sat, 05 Dec 2009 01:00:23 GMT
ee apps or other plugins can't contain gbeans
---------------------------------------------

                 Key: GERONIMO-4974
                 URL: https://issues.apache.org/jira/browse/GERONIMO-4974
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
          Components: deployment, osgi
    Affects Versions: 3.0
            Reporter: David Jencks
             Fix For: 3.0


right now the deployer adds packages it can detect as used in a gbean to the Import-Packages.
 However it never populares Export-Package.  This causes problems if the class is actually
in the plugin/bundle we are constructing.  If a bundle contains a class, if it lists the package
in Import-Package, it won't satisfy the constraint itself unless the package is also listed
in Export-Package.

So, we need to make the deployer list all the packages contained in the bundle  in Export-Package.
 This might be a challenge in case there are embedded jars and a complicated Bundle-Classpath.

For now the workaround appears to be to move any classes used in gbeans to another bundle
rather than packing them in a javaee app.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message