geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan <xhh...@gmail.com>
Subject Re: Some spec API changes while compiling Tomcat 7 with Geronimo Servlet/JSP API
Date Fri, 11 Dec 2009 08:21:32 GMT
I have pushed the latest jsp_2.1-mr2 and forked Tomcat 7 to the snapshot
site, so now, it should be easily to compile Tomcat plugin.

2009/12/10 Ivan <xhhsld@gmail.com>

> Hmm, seems that I forgot to update the jsp spec version in the
> geronimo_tomcat_7.0.0.0, please update the codes. You might need to update
> and compile jsp 1.0.2.-snapshot first ( The dependency version JSP spec
> might need to change to another code base as suggested by David).
> Before compiling Geronimo plugins, please make sure all the forked Tomcat 7
> bundles could be compiled successfully.
>
>
>
> 2009/12/10 Rick McGuire <rickmcg@gmail.com>
>
>> I'm getting it trying to build the activemq plugin.  This is using a
>> completely fresh checkout as of this morning.  Here's the error information:
>>
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Failed to resolve artifact.
>>
>> Missing:
>> ----------
>> 1) org.apache.geronimo.ext.tomcat:jasper:jar:7.0.0.0-SNAPSHOT
>>
>>  Try downloading the file manually from the project website.
>>
>>  Then, install it using the command:
>>     mvn install:install-file -DgroupId=org.apache.geronimo.ext.tomcat
>> -Dartifa
>> ctId=jasper -Dversion=7.0.0.0-SNAPSHOT -Dpackaging=jar
>> -Dfile=/path/to/file
>>
>>  Alternatively, if you host your own repository you can deploy the file
>> there:
>>
>>     mvn deploy:deploy-file -DgroupId=org.apache.geronimo.ext.tomcat
>> -Dartifact
>> Id=jasper -Dversion=7.0.0.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
>> -Durl=
>> [url] -DrepositoryId=[id]
>>
>>  Path to dependency:
>>       1) org.codehaus.mojo.jspc:jspc-maven-plugin:maven-plugin:2.0-alpha-2
>>       2) org.apache.geronimo.ext.tomcat:jasper:jar:7.0.0.0-SNAPSHOT
>>
>> ----------
>> 1 required artifact is missing.
>>
>> for artifact:
>>  org.codehaus.mojo.jspc:jspc-maven-plugin:maven-plugin:2.0-alpha-2
>>
>> from the specified remote repositories:
>>  wasce-maven-proxy (http://cemaven.cn.ibm.com/maven-proxy/repository),
>>  ibiblio.org (http://repo.exist.com/maven2)
>>
>>
>> Rick
>>
>>
>> Ivan wrote:
>>
>>> Where did you get the error about missing
>>> o.a.g.ext.tomcat:jasper:jar:7.0.0.0-SNAPSHOT , geronimo-tomcat-7.0.0.0 or
>>> plugins/tomcat ?
>>>
>>>
>>> 2009/12/10 Rick McGuire <rickmcg@gmail.com <mailto:rickmcg@gmail.com>>
>>>
>>>
>>>    Ivan wrote:
>>>
>>>        Hi,
>>>           While compiling Tomcat 7 with our own Servlet/JSP API,
>>>        there are some errors about method signature changes. So far,
>>>        I have no access to the new specs, if anyone could, please
>>>        help to check it.
>>>           javax.servlet.jsp.elExpressionEvaluator
>>>           1. The parameter expectedType in all the methods are
>>>        changed to generic type Class<?>
>>>           2. javax.servlet.ServletContext
>>>               Map<String, ServletRegistration>
>>>        getServletRegistrations() -> Map<String, ? extends
>>>        ServletRegistration> getServletRegistrations();
>>>               Map<String, FilterRegistration >
>>>        getFilterRegistrations(); -> Map<String, ? extends
>>>        FilterRegistration> getFilterRegistrations();
>>>              void setSessionTrackingModes(Set<SessionTrackingMode>
>>>        sessionTrackingModes); -> void
>>>        setSessionTrackingModes(EnumSet<SessionTrackingMode>
>>>        sessionTrackingModes);
>>>         Thanks !
>>>        --        Ivan
>>>
>>>    I'm having problems building 3.0 with the recent changes made to
>>>    trunk to use the tomcat 7 version.  The big issue is the missing
>>>  org.apache.geronimo.ext.tomcat:jasper:jar:7.0.0.0-SNAPSHOT
>>>    version, but I assume it applies to all of the tomcat components.
>>>     I managed to track down the tomcat code in the sandbox, and once
>>>    I updated to the tomcat.local.directory in the pom, I ran into
>>>    this compilation problem.  This leaves me with a broken build at
>>>    this point.  How did you generate a snapshot version so that the
>>>    Geronimo trunk would compile?  Is it as simple as a missed commit
>>>    on your sandbox code?
>>>
>>>    Rick
>>>
>>>
>>>
>>>
>>> --
>>> Ivan
>>>
>>
>>
>
>
> --
> Ivan
>



-- 
Ivan

Mime
View raw message