geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Jiang <genspr...@gmail.com>
Subject Re: A wierd problem when deploying applications to Geronimo on Lotus Foundation
Date Wed, 25 Nov 2009 15:13:48 GMT
I'm using G2.1.4 in LF,  it should be a general problems.  I don't think its
a GShell specific problem.  Instead, we met this problem with both "gsh -c
deploy deploy" and "deploy.sh deploy".


On Wed, Nov 25, 2009 at 7:13 PM, chi runhua <chirunhua@gmail.com> wrote:

> Thanks Shawn for the sharing.
>
> I'll collect this info into G doc.  Could you specify the G version you are
> using, or is it a general problem in all G servers with a GShell
> environment?
>
> Jeff C
>
>
> On Wed, Nov 25, 2009 at 5:29 PM, Shawn Jiang <genspring@gmail.com> wrote:
>
>> Lotus Foundation(LF) is a customized linux OS.  We met a wierd problem
>> when deploying applications to a running Geronimo on LF.
>>
>> The deploy process is not successful and never return.   I remote debug to
>> it and found that it's caused by some native code execution when doing the
>> JLine UnixTerminal init.   Seems LF does not support some native code used
>> in UnixTerminal.
>>
>> To resolve this problem,  We have to set a system property in JAVA_OPTS
>>
>> *-Djline.terminal=jline.UnsupportedTerminal*
>>
>> to force the JLine use UnsupportedTerminal instead of UnixTerminal.  I'm
>> sending this mail to log it in case someone else might meet similar problems
>> on other platforms,
>>
>> --
>> Shawn
>>
>
>


-- 
Shawn

Mime
View raw message